summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-01 10:48:10 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-01 18:17:34 +0200
commitd3644542d9a1733f4d9da11f05084ea9ae5b6396 (patch)
tree01b7893f00a4f08984a6eb0f841f844e5308927f
parentapp-misc/bijiben: bump to 3.34.2 (diff)
downloadgentoo-d3644542.tar.gz
gentoo-d3644542.tar.bz2
gentoo-d3644542.zip
dev-libs/folks: bump to 0.13.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--dev-libs/folks/Manifest1
-rw-r--r--dev-libs/folks/files/0.13.1-meson-0.53-compat.patch31
-rw-r--r--dev-libs/folks/folks-0.13.1.ebuild83
3 files changed, 115 insertions, 0 deletions
diff --git a/dev-libs/folks/Manifest b/dev-libs/folks/Manifest
index 499f5bcc9ef8..7b6fbc09eb53 100644
--- a/dev-libs/folks/Manifest
+++ b/dev-libs/folks/Manifest
@@ -1 +1,2 @@
DIST folks-0.12.1.tar.xz 522688 BLAKE2B 584957b628e286b850ee45c3f79d942ae602124e0130eeddc8806ae6fc12accd26c140df5caa0a1a68c84bff707df785d863d2f69ee9a0b6b450b8159c21fb39 SHA512 f60e993508137b33602ccc814bde45ad780d61afb0566f8175fd01b3dcaa5f5771e11d98156c4ecfd85f920a7adc140a5b2582eaaa97568b8fb3b3761668decb
+DIST folks-0.13.1.tar.xz 515584 BLAKE2B fe4e368e60dd41a72f449f130993eb7b8792b2a38218ff7117a8e5ec192d53d2b8f5ab09a2318267cf2fd7a717048b8715289b2f411c59846c6c98235ec32149 SHA512 b134172077bed1655cd7f24b1402ed347d405b22114c33d6638040a5e475632ea33cde898a08fc143eaefc7057d4b6dccceac7e797e1976fdf88c58764818afe
diff --git a/dev-libs/folks/files/0.13.1-meson-0.53-compat.patch b/dev-libs/folks/files/0.13.1-meson-0.53-compat.patch
new file mode 100644
index 000000000000..a31a5c697e2f
--- /dev/null
+++ b/dev-libs/folks/files/0.13.1-meson-0.53-compat.patch
@@ -0,0 +1,31 @@
+From c973f2910322a2b6cfae210730bfd6d3d8259e01 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 1 Mar 2020 10:41:30 +0200
+Subject: [PATCH] meson: Disable unused dbusmock check as tests are commented
+ out
+
+This avoids issues with meson-0.53 like commit 1853567d79024, but
+by just dropping the check, because the 0.13.1 release had tests
+commented out fully anyhow.
+---
+ meson.build | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 8d09149e..8f52bb7e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -123,10 +123,6 @@ endif
+
+ if bluez_backend_enabled
+ libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+- # Needed for the BlueZ tests
+- pymod = import('python')
+- py_installation = pymod.find_installation('python3')
+- python_dbusmock = py_installation.dependency('dbusmock')
+ endif
+
+ if import_tool_enabled
+--
+2.20.1
+
diff --git a/dev-libs/folks/folks-0.13.1.ebuild b/dev-libs/folks/folks-0.13.1.ebuild
new file mode 100644
index 000000000000..600f6208d59a
--- /dev/null
+++ b/dev-libs/folks/folks-0.13.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MAX_API_VERSION="0.44" # tests-utils fails to build with newer with v0.12.1
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/25" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+IUSE="bluetooth eds +telepathy tracker utils"
+REQUIRED_USE="bluetooth? ( eds )"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libgee-0.10:0.8[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ telepathy? (
+ >=net-libs/telepathy-glib-0.19.9
+ dev-libs/dbus-glib
+ )
+ tracker? ( app-misc/tracker:0/2.0 )
+ eds? ( >=gnome-extra/evolution-data-server-3.33.2:= )
+ dev-libs/libxml2:2
+ utils? ( sys-libs/readline:0= )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${DEPEND}
+ bluetooth? ( >=net-wireless/bluez-5[obex] )
+ telepathy? ( net-im/telepathy-mission-control )
+"
+BDEPEND="
+ >=dev-util/meson-0.49
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ eds? ( gnome-extra/evolution-data-server[vala] )
+"
+
+PATCHES=(
+ # Alternative to https://gitlab.gnome.org/GNOME/folks/issues/119 as tests are commented out in 0.13.1 release
+ "${FILESDIR}"/${PV}-meson-0.53-compat.patch
+)
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth bluez_backend)
+ $(meson_use eds eds_backend)
+ $(meson_use eds ofono_backend)
+ $(meson_use telepathy telepathy_backend)
+ $(meson_use tracker tracker_backend)
+ -Dzeitgeist=false # last rited package
+ -Dimport_tool=true
+ $(meson_use utils inspect_tool)
+ -Dinstalled_tests=false
+ -Ddocs=false # Needs find_program sedding to specific version; only dev docs, don't bother
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}