summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-11 09:07:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-11 09:15:46 +0200
commitd36559a411172531d508cb7ea4d015580e2bfb60 (patch)
treeddb54509920c5a1dcd511b0d504514240a568e25
parentdev-python/translate-toolkit: Bump to 3.4.1 (diff)
downloadgentoo-d36559a4.tar.gz
gentoo-d36559a4.tar.bz2
gentoo-d36559a4.zip
dev-python/sqlparse: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlparse/Manifest1
-rw-r--r--dev-python/sqlparse/sqlparse-0.4.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sqlparse/Manifest b/dev-python/sqlparse/Manifest
index 254934698acb..ee6d965e438c 100644
--- a/dev-python/sqlparse/Manifest
+++ b/dev-python/sqlparse/Manifest
@@ -1,2 +1,3 @@
DIST sqlparse-0.3.1.tar.gz 67572 BLAKE2B 27c9267de1a269a4574019d457a3dad53ad805e56a57ba73e294c229a7852b7ca04557fb45d07566e94eba7593257ad7eb413b1e0ec04d1044838d5039dc8ba8 SHA512 4c56a528b43578a7a48fc31cee369215b15761d9903ea1d8e034c69f0eb6431dd15362aab13af25a36fccb361436f1cba746bcbb515cbab5d30319629dd2ddfb
DIST sqlparse-0.4.1.tar.gz 67228 BLAKE2B 677b592af263e94e1f6d36242f4bf75d28d0466636c0c578b83f472acf05c357b6899150ce01b594db89f2844c1b85220429857583c79e6dbba34a75bdf54e47 SHA512 49f02a63ef490c2e900cea6a0882891cd1381e0f398c4e38688444300b0f0e961c91c4f1a2355704bba7f170083594bd9e26c2a6cac934da9d87ab291accd27c
+DIST sqlparse-0.4.2.tar.gz 67771 BLAKE2B 790ba224ed04ce1952602e7d01a2f0bd7e830e62a38c35d69c3fcd2b5b1016560a1e23c24ec82ff4b2e7021cbeab17968b9cff01acc8674fa18a05ab88efb84b SHA512 8136e5c14650b5286616958bfb19039a6981e4c84bf955b0f668053f5427202eff9a6472f71820293ddbe55c0f793fb690d42d0e0134135aed7eb6e13edca01e
diff --git a/dev-python/sqlparse/sqlparse-0.4.2.ebuild b/dev-python/sqlparse/sqlparse-0.4.2.ebuild
new file mode 100644
index 000000000000..d79dc3ab5a84
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${P#python-}
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest