summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-06 07:59:44 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-06 08:00:52 +0200
commitd36614853c0f4dda3e12040598803c58aa0d35d7 (patch)
tree128a48a87c95dbde4930a30c96b6d81c6fbe2178
parentnet-analyzer/cacti: Version 1.2.11 (diff)
downloadgentoo-d36614853c0f4dda3e12040598803c58aa0d35d7.tar.gz
gentoo-d36614853c0f4dda3e12040598803c58aa0d35d7.tar.bz2
gentoo-d36614853c0f4dda3e12040598803c58aa0d35d7.zip
net-analyzer/cacti-spine: Version 1.2.11
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.11.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index fe07bfec9ff5..fab16d246ef8 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-1.2.10.tar.gz 106625 BLAKE2B 8038fb4352b71d5885b07d2ca5af76c38369d2a904f1b669da31a82b0d25bcebf63c5facdb268ee5f4c6bc4bf4772f120bbf85101831cea9ac7d469ed93b27f9 SHA512 56e796a613037b49e54fa07654f337ac7522cb9ead81673f3e1dcd61b29d152b997a2f46a7c2b28409944ffd3ba3afa70d4867f2d0ff7f58525372bae41f1048
+DIST cacti-spine-1.2.11.tar.gz 107495 BLAKE2B faa2356e374f392565d3a1fed446527bd5be9cf63ec1b286e0e6069503b80fea9042d367f087f05ff5660a0fb647a2d2478c6f25a557b8aec821a151af2a7f02 SHA512 6c7dd2c4b35040cce58714e1b238b473d42465327cde469cb09c304d51fe74b0731ec4ed4d70321c092d6efd4eac6ab375140beb5d552fcf7ad4286713a4f22b
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.11.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.11.ebuild
new file mode 100644
index 000000000000..a5c1da23c064
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}