summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-11-13 17:34:40 +0100
committerCraig Andrews <candrews@gentoo.org>2020-11-13 12:50:00 -0500
commitd366c82468085fe5f14220e383c342e496eb4258 (patch)
treed842106483cc7ae4bcd6ed8626cd7289fdac2bc7
parentsys-kernel/zen-sources: delete empty line (diff)
downloadgentoo-d366c82468085fe5f14220e383c342e496eb4258.tar.gz
gentoo-d366c82468085fe5f14220e383c342e496eb4258.tar.bz2
gentoo-d366c82468085fe5f14220e383c342e496eb4258.zip
dev-libs/rocm-device-libs: Correcting install location according to FHS
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.8, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18244 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocm-device-libs/rocm-device-libs-3.9.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/rocm-device-libs/rocm-device-libs-3.9.0-r1.ebuild b/dev-libs/rocm-device-libs/rocm-device-libs-3.9.0-r1.ebuild
new file mode 100644
index 000000000000..507a68912932
--- /dev/null
+++ b/dev-libs/rocm-device-libs/rocm-device-libs-3.9.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-Device-Libs/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-Device-Libs-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Device Libraries"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-Device-Libs"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/OCL.cmake" || die
+ sed -e "s:amdgcn/bitcode:lib/amdgcn/bitcode:" -i "${S}/cmake/Packages.cmake" || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/lib/cmake/llvm"
+ )
+ cmake_src_configure
+}