summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2023-04-28 20:40:23 +0200
committerHanno Böck <hanno@gentoo.org>2023-04-28 20:40:23 +0200
commitd3755e075dd017ebb76976652a69e544e826a42d (patch)
tree311e925d1c41be91f4df1b9186226a9f47c12703
parentnet-libs/nodejs: fix build for 16.20.0 (diff)
downloadgentoo-d3755e07.tar.gz
gentoo-d3755e07.tar.bz2
gentoo-d3755e07.zip
app-text/uudeview: Fix implicit function declaration
Avoids issues with clang 16. Closes: https://bugs.gentoo.org/900535 Signed-off-by: Hanno Böck <hanno@gentoo.org>
-rw-r--r--app-text/uudeview/files/uudeview-0.5.20-fix-implicit.diff12
-rw-r--r--app-text/uudeview/uudeview-0.5.20-r4.ebuild44
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/uudeview/files/uudeview-0.5.20-fix-implicit.diff b/app-text/uudeview/files/uudeview-0.5.20-fix-implicit.diff
new file mode 100644
index 000000000000..30b900d4509b
--- /dev/null
+++ b/app-text/uudeview/files/uudeview-0.5.20-fix-implicit.diff
@@ -0,0 +1,12 @@
+diff --git a/configure.in b/configure.in
+index 4ea5965..49100ff 100644
+--- a/configure.in
++++ b/configure.in
+@@ -518,6 +518,7 @@ AC_CHECK_FUNC([mkstemp],,[AC_MSG_ERROR([needs mkstemp])])
+ #
+ AC_MSG_CHECKING([for strerror])
+ AC_TRY_LINK([
++#include <string.h>
+ char *blubb() { return (char *) strerror (42); }
+ ],[
+ (void) blubb();
diff --git a/app-text/uudeview/uudeview-0.5.20-r4.ebuild b/app-text/uudeview/uudeview-0.5.20-r4.ebuild
new file mode 100644
index 000000000000..7ec9c8a0f37f
--- /dev/null
+++ b/app-text/uudeview/uudeview-0.5.20-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="uu, xx, base64, binhex decoder"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bugfixes.patch
+ "${FILESDIR}"/${P}-CVE-2004-2265.patch
+ "${FILESDIR}"/${P}-CVE-2008-2266.patch
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-rename.patch
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-fix-append_signature.patch
+ "${FILESDIR}"/${P}-string_format_issue.patch
+ "${FILESDIR}"/${P}-format-string-warning-inews.patch
+ "${FILESDIR}"/${P}-fix-function-definitions-clang16.patch
+ "${FILESDIR}"/${P}-fix-implicit.diff
+)
+
+DOCS=( HISTORY INSTALL README )
+
+src_prepare() {
+ sed -i "s:^\tar r:\t$(tc-getAR) r:" uulib/Makefile.in || die
+
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-tcl \
+ --disable-tk
+}