summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Jakobi <tjakobi@math.uni-bielefeld.de>2021-05-05 21:15:53 +0200
committerAaron Bauman <bman@gentoo.org>2021-08-05 18:10:53 +0300
commitd37ea06a15d867cd0cf23a232ce26cfc48c6354f (patch)
treea5c9c3eb9b40b92e7721acd0e89ae015fc52b053
parentdev-java/openjfx: do not strip / from swt_file_name. (diff)
downloadgentoo-d37ea06a15d867cd0cf23a232ce26cfc48c6354f.tar.gz
gentoo-d37ea06a15d867cd0cf23a232ce26cfc48c6354f.tar.bz2
gentoo-d37ea06a15d867cd0cf23a232ce26cfc48c6354f.zip
gui-apps/slurp: add version 1.3.2
- released on 17th April 2021 - introduces -o argument so slurp can be used as output chooser for xdg-desktop-portal-wlr Bug: https://bugs.gentoo.org/771966 Signed-off-by: Tobias Jakobi <tjakobi@math.uni-bielefeld.de> Closes: https://github.com/gentoo/gentoo/pull/20693 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--gui-apps/slurp/Manifest1
-rw-r--r--gui-apps/slurp/slurp-1.3.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
index a07473c5b6e2..55e3f975e91b 100644
--- a/gui-apps/slurp/Manifest
+++ b/gui-apps/slurp/Manifest
@@ -1 +1,2 @@
DIST slurp-1.2.0.tar.gz 15317 BLAKE2B 92de74abb54b2d53334e0f0c5d08b0b50e9c4583eb192226e38fcefa07cce2265f808ce81c04170e65d3c1209fa263352e3d70cc0a7cf745ed5e18d57c4d3af6 SHA512 443cd497049a5128e80a48c7b2afcc555a8d58a5eacc2dc6207058a9a399bc9e9804c7bca8b010af63f8be99000c05245720bd3e8cca248a74d5aa63a7faf4f9
+DIST slurp-1.3.2.tar.gz 17734 BLAKE2B 42795f1927742ce9606c685a49f2fb395905c875b50b50b60b68bf129d3c6743278a0eeaed72b94921dd65bd4ca4c078c24c693029cff84dbcbe20165242653c SHA512 9e7f9e4b46095fce5dcc05f8d04b5e576771d15080a0ec451a8a5df681d5ab818cb4d5284a74e1650f775e2d05ca32d66551d8e333d6002827c8b60b12d6bb28
diff --git a/gui-apps/slurp/slurp-1.3.2.ebuild b/gui-apps/slurp/slurp-1.3.2.ebuild
new file mode 100644
index 000000000000..e2e9ec21244d
--- /dev/null
+++ b/gui-apps/slurp/slurp-1.3.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}