summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-30 19:16:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-30 19:46:27 +0100
commitd38e95d9183a278c4a867f81fb85ea88cc3f049a (patch)
tree938738e9aafefc8eeca103b8221457ca384f4cee
parentdev-python/django-redis: Bump to 5.1.0 (diff)
downloadgentoo-d38e95d9.tar.gz
gentoo-d38e95d9.tar.bz2
gentoo-d38e95d9.zip
dev-python/diskcache: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-5.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 64ee0c84cb5e..c2ea80f79d8c 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1 +1,2 @@
DIST diskcache-5.2.1.gh.tar.gz 652769 BLAKE2B 25fcdcf51c8be7a6e2a9de645258f776647789a7f06c70c8564ad28bd003a745167095b11a54d435e733d9f5181a1443be2510fe2d901cc208ea426d3359c0ba SHA512 6e55bada12145d931f4a465092decc3f2cfed2e618d1ea271ad6daa6caf7c3abfd6ae5de11072efdf898ebf272acd39136136b58d7b5e735092963bdd46af52e
+DIST diskcache-5.3.0.gh.tar.gz 653506 BLAKE2B 250420da434fa8a02cf58ed552072cb62a6d10dfa3801cf187db327a687763ab7f010c19f5e10b9ba71b2fd6830ba902750ca273c8be08c6f7987aa0923afcff SHA512 106c8eb8320153e42e076927d51fa75d30b92156e17a75756e0392028cb6b5054af9af66b93aa69b7a7105012f0b92fe942ee447a75e53e005b56eb0b067dc38
diff --git a/dev-python/diskcache/diskcache-5.3.0.ebuild b/dev-python/diskcache/diskcache-5.3.0.ebuild
new file mode 100644
index 000000000000..dc919174075d
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+BDEPEND="
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ )"
+
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_djangocache.py::DiskCacheTests::test_get_or_set_callable_returning_none
+ tests/test_djangocache.py::DiskCacheTests::test_pickle
+)
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}