summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-12-01 18:12:12 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-12-01 18:14:19 +0000
commitd3907a414745d8b6a24cfcf8ed51a321bb9201d5 (patch)
tree22a0dfeaf16ed2d1a44872428aaab4b98c8f8813
parentdev-ruby/facter: bup (diff)
parentmedia-plugins/alsa-plugins: version bump to 1.1.0 (diff)
downloadgentoo-d3907a414745d8b6a24cfcf8ed51a321bb9201d5.tar.gz
gentoo-d3907a414745d8b6a24cfcf8ed51a321bb9201d5.tar.bz2
gentoo-d3907a414745d8b6a24cfcf8ed51a321bb9201d5.zip
Merge remote-tracking branch 'remotes/joe-konno-gitlab/topic/gentoo-565434-v2'
Joe Konno has contributed ebuilds for bug #565434
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.1.0.ebuild87
-rw-r--r--media-plugins/alsa-plugins/Manifest1
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.1.0.ebuild101
-rw-r--r--media-sound/alsa-tools/Manifest1
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.1.0.ebuild143
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.1.0.ebuild78
-rw-r--r--media-sound/alsa-utils/metadata.xml1
9 files changed, 414 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index 36cb87402cac..8f18d59c3982 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,3 +1,4 @@
DIST alsa-lib-1.0.27.2.tar.bz2 906844 SHA256 690ed393e7efd4fc7e3a2d2cda5449298ca0c895197e5914e350882012430d19 SHA512 3fa9160e001cf21ddc6332c3748f8aa27bd1b514616fd1a9993c34128fe99d07e2dfc5f1a9177e1c17456d1361496f90bf3552f940fd85c6ea5ac9bbc30fe8ce WHIRLPOOL d5df07a99abe4fe7842ef9fe2718148f17db0a182ef0315ec5c32e2ea20ea2a2da007f880dbc2954efc5a2d61dd5e92038a45d8172bee29d8af13532dcdd4afd
DIST alsa-lib-1.0.28.tar.bz2 903786 SHA256 3c074b85dde1b30e78ef4995579765833e5b693fbbd8f834c335e080cb734a6d SHA512 a08430d0beb4a751b1608d148f4fc3d1077a689f5f7197b830a2768d66238b69de2614448d56643fbcb3141faa06ab361b7a8579cce4303304bce8c10de01f08 WHIRLPOOL db51ab59cfce545a4790c423a141846996d2fa2db7134b3cf17562e7e1d70bc4c56052edda9e6bfcd6f38ca9750f266bcec845b66c43402340f187a945a1098b
DIST alsa-lib-1.0.29.tar.bz2 905417 SHA256 73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0 SHA512 c9c2dcd3105abadcfdff104770a1f7683d83f6b9df64eebe9f9efc1ecab3ca4cef43718b5b15526bdabf2862ce55ec665732bb0390fc8e6492e2c1cebec9294c WHIRLPOOL 330877960733e847c12f133f93acc58a2053303b4437c5aaf21e2c4df0c47389df28ed093ab6606ee3cb854389b359d981dc547fba08bab03cff1c99f93e72d8
+DIST alsa-lib-1.1.0.tar.bz2 929874 SHA256 dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15 SHA512 2939d0b621c1c619b0a492b05f2e84f354d588c9cc982d93dbcf01c582319258dd5f803ff5c10be52343cd8827d690f671ab5b20ad586a0ee371f0949c9e98f4 WHIRLPOOL b82bdf72ed5cd23517270a1e81407670d2af2794fa14decf9513643f270281affe978eef9bc61cd76eea529751461ab016fc0e187b36e2527bec02674e5ee8a8
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild
new file mode 100644
index 000000000000..8189fca548c0
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # https://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ dohtml -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}
diff --git a/media-plugins/alsa-plugins/Manifest b/media-plugins/alsa-plugins/Manifest
index 1e8b1981b60b..ea4e4ca8def2 100644
--- a/media-plugins/alsa-plugins/Manifest
+++ b/media-plugins/alsa-plugins/Manifest
@@ -1,3 +1,4 @@
DIST alsa-plugins-1.0.27.tar.bz2 363593 SHA256 0bbd0c37c2dd7baf16363afb2e58169ffb0f9c0a70031b3b6235594630f3ab35 SHA512 73c2010b66022429bc664bdab1c03694dfd669260dea569e32496bc6e10a11a0da2dd87db6a661ab1376f3aa59f1df8a84cb48ff1d20bb064756c655203f9993 WHIRLPOOL 4487734e0377c880a46df6f7fa53d86a7c38fa3d4bd35e06d128c0ec2b99c789ed64674b59003d8bd0abce2db53301234e467d235532ea145ddb150919cb49af
DIST alsa-plugins-1.0.28.tar.bz2 366023 SHA256 426f8af1a07ee9d8c06449524d1f0bd59a06e0331a51aa3d59d343a7c6d03120 SHA512 c79cf22f426f500c704c947af602604c62a76a026c9b945589d1ca83dff16de23cec2f1c29c9713e42736092aa0d0389e514ca2ca646f8e4770c8aa8320725cc WHIRLPOOL 9cb54e2a30a3f682aa23acb6317f267ffb3cd47eceb959fbce73c8db3ba7c8af420b91b91cce865f0aaf0c60b2920f51972640aff8413c871d0709fa7f4f90a6
DIST alsa-plugins-1.0.29.tar.bz2 366077 SHA256 325d85cac285f632b83e0191ae3f348bad03c1f007b937042f164abb81ea6532 SHA512 6bc7d417ee5deb00a6e36864778deb4675a186951747cc799386288704f0d22a5c3d7011b6091602378d02ee79c4696ebb879140cebea392bd68937c8640898a WHIRLPOOL 987c348b536b03b36c2e7f9bff733e5309961b6f052d6a76f1372eb231d9af92191c113d0a577221809b0fcc4bc9614f278afb10472bd1606822aab468210af3
+DIST alsa-plugins-1.1.0.tar.bz2 366296 SHA256 3b83c329953bef99f5fe25ae04ec4a455fe6514939f3b45a5321966652b2c9ee SHA512 5ed31ce1b6d11232d464d3cdef6015403840edbf2154266a479c2fde12ef4506e1f20c0f405ccee9cc39aec80be3bc41b10798a4475494ba56c6b4d69637fdc9 WHIRLPOOL 32c8460ed27a6a554f983e476e09847940e152cbc7b8cf0909243d312091560b1b25360249e3edeae50a46c5990f216cfd17915ec539812a5c473406705c2e73
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.1.0.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.1.0.ebuild
new file mode 100644
index 000000000000..667bf33122c9
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.1.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib multilib-minimal
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="debug ffmpeg jack libav libsamplerate pulseaudio speex"
+
+RDEPEND="
+ >=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.121.3-r1[${MULTILIB_USEDEP}] )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.8-r1:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ speex? ( >=media-libs/speex-1.2_rc1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.23-automagic.patch
+ epatch "${FILESDIR}"/${PN}-1.0.28-libav10.patch
+ has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}"/${PN}-1.0.29-ffmpeg29.patch
+
+ epatch_user
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myspeex=no
+ use speex && myspeex=lib
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ --with-speex=${myspeex}
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ cd doc || die
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ # bug #410261, comment 5+
+ # seems to work fine without any path
+ sed -i \
+ -e "s:/usr/lib/alsa-lib/::" \
+ "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
+ fi
+
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}
diff --git a/media-sound/alsa-tools/Manifest b/media-sound/alsa-tools/Manifest
index 820437fe8809..7412348c24dd 100644
--- a/media-sound/alsa-tools/Manifest
+++ b/media-sound/alsa-tools/Manifest
@@ -1,3 +1,4 @@
DIST alsa-tools-1.0.27.tar.bz2 1650746 SHA256 6562611b5a6560712f109e09740a9d4fa47296b07ed9590cb44139c5f154ada2 SHA512 aad985329e5649b5bd7c142e95c5d1c415f28bac1afb81ad21fedac76e736d18abe4aa129e798650d91b2dd14fb18f3960ed5218768c689319c2360c432b4589 WHIRLPOOL 0d827aee4219e393c61a55920e3d66eb4e208e9d3d93ac9c1bf208c5c0c8cdf2d58f63d70b534458f3542cd3cbd5478129d73aecc57ce6654bc43f0bc73c0f25
DIST alsa-tools-1.0.28.tar.bz2 1675680 SHA256 76e59711c6d0f39cbddce83ce1ed8da00bad112fee021f94fa990d8685cc3761 SHA512 b5150edb5f5124d5ec256b7c3348207da1bb9847ab2f10297171d6a43f559a31429ef96608a2c670db75d269dd940ebf2b6e3cbfafde530de25cbd95dce31af2 WHIRLPOOL 20f8acf8edf3fa82f19e4098c520c155a87966272d769f29a6208b25fc80a831a6cfdb3c748406ced643b5de7fa4cfb43f3a62d634fd90512369b1f57ea9cb92
DIST alsa-tools-1.0.29.tar.bz2 1715439 SHA256 94abf0ab5a73f0710c70d4fb3dc1003af5bae2d2ed721d59d245b41ad0f2fbd1 SHA512 c236e105106e65b9f02e5baed536fa33f8efcff21a75470127e2edacf0bbb3ec555131e146d9dbfc8da307355b372e7c2acaf8edaa98dc7880abd484fbdb2813 WHIRLPOOL 19d34f425ad45d540a0ccd2ae2c77bae810ee6039250f57296c280156c6e6ed8d3788f306975f6b06b8b3f377e714d644aed08c177bd9d83acf352ccb939a47d
+DIST alsa-tools-1.1.0.tar.bz2 1715113 SHA256 7d34558c590a50294b36576d257316a1ac5cd951eb8cd7d330e09f8cc757ab51 SHA512 caabbc9a8b494de6bba0dea6440b335b35e5c7dab4942ac36f127a75c2212ff98e7e38566444666edcf40c6c95e6d9797c421014fb5c5c292bb398780e6c9f87 WHIRLPOOL daf731da17c172275b484da37962d85569d70066392bb65f6b462a5f9f17784d204deec203d2466cbc08cb691689b7fc8cd664b370b39e233f1e8afb43c9d0ff
diff --git a/media-sound/alsa-tools/alsa-tools-1.1.0.ebuild b/media-sound/alsa-tools/alsa-tools-1.1.0.ebuild
new file mode 100644
index 000000000000..319851c64dd1
--- /dev/null
+++ b/media-sound/alsa-tools/alsa-tools-1.1.0.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Advanced Linux Sound Architecture tools"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="fltk gtk alsa_cards_hdsp alsa_cards_hdspm alsa_cards_mixart
+alsa_cards_vx222 alsa_cards_usb-usx2y alsa_cards_sb16 alsa_cards_sbawe
+alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ice1712
+alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sscape alsa_cards_pcxhr"
+
+COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
+ >=dev-python/pyalsa-1.0.26
+ fltk? ( >=x11-libs/fltk-1.3.0:1 )
+ gtk? (
+ >=dev-python/pygtk-2
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ )" #468294
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( media-fonts/font-misc-misc )" #456114
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ ALSA_TOOLS="seq/sbiload us428control hwmixvolume hda-verb"
+
+ if use gtk; then
+ ALSA_TOOLS="${ALSA_TOOLS} hdajackretask"
+ use alsa_cards_ice1712 && \
+ ALSA_TOOLS="${ALSA_TOOLS} envy24control"
+ use alsa_cards_rme32 && use alsa_cards_rme96 && \
+ ALSA_TOOLS="${ALSA_TOOLS} rmedigicontrol"
+ fi
+
+ if use alsa_cards_hdsp || use alsa_cards_hdspm; then
+ ALSA_TOOLS="${ALSA_TOOLS} hdsploader"
+ use fltk && ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
+ fi
+
+ use alsa_cards_mixart && ALSA_TOOLS="${ALSA_TOOLS} mixartloader"
+ use alsa_cards_vx222 && ALSA_TOOLS="${ALSA_TOOLS} vxloader"
+ use alsa_cards_usb-usx2y && ALSA_TOOLS="${ALSA_TOOLS} usx2yloader"
+ use alsa_cards_pcxhr && ALSA_TOOLS="${ALSA_TOOLS} pcxhr"
+ use alsa_cards_sscape && ALSA_TOOLS="${ALSA_TOOLS} sscape_ctl"
+
+ { use alsa_cards_sb16 || use alsa_cards_sbawe; } && \
+ ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
+
+ if use alsa_cards_emu10k1 || use alsa_cards_emu10k1x; then
+ ALSA_TOOLS="${ALSA_TOOLS} as10k1 ld10k1"
+ fi
+
+ use gtk && ALSA_TOOLS="${ALSA_TOOLS} echomixer"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/envy24control-config-dir.patch
+
+ epatch_user
+
+ # This block only deals with the tools that still use GTK and the
+ # AM_PATH_GTK macro.
+ for dir in echomixer envy24control rmedigicontrol; do
+ has "${dir}" "${ALSA_TOOLS}" || continue
+ pushd "${dir}" &> /dev/null
+ eautoreconf
+ popd &> /dev/null
+ done
+
+ # This block deals with the tools that are being patched
+ for dir in hdspconf; do
+ has "${dir}" "${ALSA_TOOLS}" || continue
+ pushd "${dir}" &> /dev/null
+ eautoreconf
+ popd &> /dev/null
+ done
+
+ elibtoolize
+}
+
+src_configure() {
+ if use fltk; then
+ # hdspmixer requires fltk
+ append-ldflags "-L$(dirname $(fltk-config --libs))"
+ append-flags "-I$(fltk-config --includedir)"
+ fi
+
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ case "${f}" in
+ echomixer,envy24control,rmedigicontrol )
+ econf --with-gtk2
+ ;;
+ * )
+ econf
+ ;;
+ esac
+ done
+}
+
+src_compile() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ emake
+ done
+}
+
+src_install() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ # Install the main stuff
+ cd "${S}/${f}"
+ # hotplugdir is for usx2yloader/Makefile.am
+ emake DESTDIR="${D}" hotplugdir=/lib/firmware install
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog AUTHORS; do
+ if [[ -f "${doc}" ]]; then
+ mv "${doc}" "${doc}.$(basename ${f})" || die
+ dodoc "${doc}.$(basename ${f})"
+ fi
+ done
+ done
+
+ # Punt at least /usr/lib/liblo10k1.la (last checked, 1.0.27)
+ prune_libtool_files
+}
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 2e150b000689..af489eb12702 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,3 +1,4 @@
DIST alsa-utils-1.0.27.2.tar.bz2 1143802 SHA256 02bfac39092f3b68d743c23ad3d688d6c5aa8df69f2ccd692c5b8282edb352ea SHA512 c9a4943852ec1a71a5a8d2c99e1df0ba96a5d9d1196cabfdb6655f58c6a9a5a9d40dea62de019f5ed0fad0885800403c48a4a6c86b67af7fbd842097881c2bd6 WHIRLPOOL 9e95c37f307498bb9a7829fd721bf54888f3fe9ec78f014702cc26493e81369a44b571f1f5e65b3e32dbde926f97ab1152e22cf66fdff17be209e61ae34d9d46
DIST alsa-utils-1.0.28.tar.bz2 1146887 SHA256 f3ff4c89b0125a7797b1b13cd094cc92276e655458274967386e812d03642acc SHA512 faa5abf3f066106c80d019944efa2298e2d3157469c1c7bc52deb9aa1bcd5f5439a2e22b04ad9210e292fcef97bdacc27aa75fc275d0d7cae2c2f88729c84786 WHIRLPOOL d58587d9f302f3f1a7ab4de45c3889ce82e5be782e4aa9a953c39a908a4693e99c8ea9aeeb5669f0f606d980983beb7d5fc53e4c76ce1bb76500c7c2bcb45013
DIST alsa-utils-1.0.29.tar.bz2 1154497 SHA256 5160058f3e14483ced5de919dd473f93932059454530a9b7ef97dcabd6833e9b SHA512 0d83805aa7b1c975524cc5ecd4aa6eb36126bc434458f9e9475e4bd1b14bbb4bf9691096ca7973342a3798e97a361451c078f4595f8f4275db64d6b443ca5928 WHIRLPOOL ccad5115148045e0c5f139d70306e801e250aa3946f60d9cd0a47c84c72f6d8689e53105030589309c98ddd4a7b871bb8dc03f00fcc3d46cc3e08c4718299407
+DIST alsa-utils-1.1.0.tar.bz2 1181085 SHA256 3b1c3135b76e14532d3dd23fb15759ddd7daf9ffbc183f7a9a0a3a86374748f1 SHA512 c61f056959feba015bb4a6f49980c4beb6a0c34be09e7196864583897ea86373b593a8807999a07df9c87a3a0c714075b9aae516752e83a946d0d60bc8f90f98 WHIRLPOOL 50d8e1506fb9f969b3dfcd618933efbeda6f938c3350eccf99526fb8329afd1ea4381ff1a548590f0f9bae12bdb63c1e8ab068641743d52b3ba609eae2d337e5
diff --git a/media-sound/alsa-utils/alsa-utils-1.1.0.ebuild b/media-sound/alsa-utils/alsa-utils-1.1.0.ebuild
new file mode 100644
index 000000000000..29cb35706f0c
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="bat doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
+ bat? ( sci-libs/fftw )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable bat) \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r6 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}
diff --git a/media-sound/alsa-utils/metadata.xml b/media-sound/alsa-utils/metadata.xml
index 031bd1ce91f0..128591833ac1 100644
--- a/media-sound/alsa-utils/metadata.xml
+++ b/media-sound/alsa-utils/metadata.xml
@@ -6,6 +6,7 @@
<email>alsa-bugs@gentoo.org</email>
</maintainer>
<use>
+ <flag name="bat">install basic audio tester (BAT) util</flag>
<flag name="libsamplerate">install utils that use libsamplerate (e.g. alsaloop)</flag>
<flag name="ncurses">install utils that use ncurses (e.g. alsamixer)</flag>
</use>