summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-29 08:49:43 +0000
committerSam James <sam@gentoo.org>2023-01-29 08:50:30 +0000
commitd39384a1e63934c262edf027422121f7fa3e9e69 (patch)
tree43f329dec8fba0d55136728fd135cb2768784eca
parentwww-client/firefox: support mold linker in 109.0 (diff)
downloadgentoo-d39384a1.tar.gz
gentoo-d39384a1.tar.bz2
gentoo-d39384a1.zip
sys-devel/gcc: update musl patchset for 10.x
Fixes cross-compilation on ppc/x86 and other special arches wrt ssp for musl. Bug: https://bugs.gentoo.org/862831 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/gcc/Manifest1
-rw-r--r--sys-devel/gcc/gcc-10.4.1_p20230119-r1.ebuild2
-rw-r--r--sys-devel/gcc/gcc-10.4.1_p20230126.ebuild2
3 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index 4947c829dafa..287c466fad09 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -5,6 +5,7 @@ DIST gcc-10.4.0-musl-patches-1.tar.xz 3808 BLAKE2B 804d1fcc451dcd03be71240dd498e
DIST gcc-10.4.0-patches-5.tar.xz 17056 BLAKE2B f336d69a8ad105b8c4a84e8248a5b8a88175d3f1d67d32c6bee1780d252d86947059bd624992e6292610e86c9012f4d901a1a54df0d184dd023d404a0707700e SHA512 aa8fb42f20587f8519e7b06037da4d8f7d386b63e228b239a0445a51df4e401940fcd81482381d966622054aef3e0db06d1def5c74ac3d3dcc9c75c3b966c758
DIST gcc-10.4.0.tar.xz 75018092 BLAKE2B ec1169025d3896b70ab80a4b8ce5040763a95529fc7e120c6bc3a3eb1db5cf938ebde347c1e595a8ff7d4081e79ded6252702d7a1a09648449b7a0783188e434 SHA512 440c08ca746da450d9a1b35e8fd2305cb27e7e6987cd9d0f7d375f3b1fc9e4b0bd7acb3cd7bf795e72fcbead59cdef5b6c152862f5d35cd9fbfe6902101ce648
DIST gcc-10.5.0-musl-patches-1.tar.xz 3816 BLAKE2B 5995f934a40665d877342853fde8b414eed8770c72e6b11b295b7e7b3c9d38d7407dff63b5751f4449f6fa842c02e87f156cc868e7436a8313f7c8514242d255 SHA512 b93cc54cd7b78fdc487df7c449b03bbfd10094e45f3f8eef20cd69f27a68a14817fe662a2ec119b384eea2dad0491b70f838d010457e386700030b76457afad6
+DIST gcc-10.5.0-musl-patches-2.tar.xz 3452 BLAKE2B 5387e516d07d81477b3f39b8b3bd986bf861d32cd25dc5481c97bd3620d00c918c5661e86857f66dbf28a655401a53e43417f638c443e44cbfdbf5e950caac4d SHA512 86f2ce31cc4fc4fb5a6043fb527bf822d895e1a6220652024f78a1cbd5a962edb6be8dc5f43c32053e075f39bb2350ea8f14e7d57e0473dd2933a7b44676bde5
DIST gcc-10.5.0-patches-1.tar.xz 17180 BLAKE2B d8ecc7cc15fa1ab420fa9eff11173a1d5544b369720e8c54fc59375e591ebd0a429b7e81a2a3df86bd2eaf19e4b8148bf2e1b0c8410de3944d4801ce412016b2 SHA512 5855aa23ee0b262c20a1b6fd2d4a947180c079dc00e0fa675043edceee0c822eec0dc752f5fcb281b70c04e50c6fcaf6c5d5160ab15d3f0c51fa030eb2d79d26
DIST gcc-10.5.0-patches-4.tar.xz 17880 BLAKE2B f368b741fd42199c85b770ec45a5232d27295cf7796163251f24fa963f2264c473e161bb34e66b43c4b227e41859d540a66331111392478b280b289d359806c6 SHA512 94f7fbd1b4672f0378c85ac3a96f7954cd22bd7cc1013c32519bbe1cae0ebb5183e14469c61dfc9d931b8d1c261f2ead1c4b47278104d1b5189a0c787aabc40e
DIST gcc-10.5.0-patches-5.tar.xz 17324 BLAKE2B e97b471fb6115fd0421be8a6390f7d88312de7ac0132fde3aa43dbf2a49d3bc640ec05f766f20363f033adeaf0430e90c42b5a6f92a422d1a82128f119e769f6 SHA512 2589b8a3be0bc60dd7b205ef9955dfd1ba525508879b30ee8057779d2677783c7c13a0bf901bc2a126e15c52d440663e6fe22a299d935e0706a037406e1cfb31
diff --git a/sys-devel/gcc/gcc-10.4.1_p20230119-r1.ebuild b/sys-devel/gcc/gcc-10.4.1_p20230119-r1.ebuild
index 89e1232159e1..c11d6837193f 100644
--- a/sys-devel/gcc/gcc-10.4.1_p20230119-r1.ebuild
+++ b/sys-devel/gcc/gcc-10.4.1_p20230119-r1.ebuild
@@ -8,7 +8,7 @@ TOOLCHAIN_PATCH_DEV="sam"
#TOOLCHAIN_GCC_RC=1
PATCH_GCC_VER="10.5.0"
PATCH_VER="4"
-MUSL_VER="1"
+MUSL_VER="2"
MUSL_GCC_VER="10.5.0"
if [[ $(ver_cut 3) == 9999 ]] ; then
diff --git a/sys-devel/gcc/gcc-10.4.1_p20230126.ebuild b/sys-devel/gcc/gcc-10.4.1_p20230126.ebuild
index c89d4e49e425..68d9c2522686 100644
--- a/sys-devel/gcc/gcc-10.4.1_p20230126.ebuild
+++ b/sys-devel/gcc/gcc-10.4.1_p20230126.ebuild
@@ -8,7 +8,7 @@ TOOLCHAIN_PATCH_DEV="sam"
#TOOLCHAIN_GCC_RC=1
PATCH_GCC_VER="10.5.0"
PATCH_VER="5"
-MUSL_VER="1"
+MUSL_VER="2"
MUSL_GCC_VER="10.5.0"
if [[ $(ver_cut 3) == 9999 ]] ; then