summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-12-12 21:08:38 +0100
committerGuilherme Amadio <amadio@gentoo.org>2021-12-14 15:58:24 +0100
commitd39c7e1a3a4c5f63f70d00c4ab558801d339e46a (patch)
treed86f8cf0d483b7b61a866c4dc3580ca1d04c3c40
parentdev-python/ipykernel: fix bug #784764 (diff)
downloadgentoo-d39c7e1a3a4c5f63f70d00c4ab558801d339e46a.tar.gz
gentoo-d39c7e1a3a4c5f63f70d00c4ab558801d339e46a.tar.bz2
gentoo-d39c7e1a3a4c5f63f70d00c4ab558801d339e46a.zip
sci-physics/geant4_vmc: Bump to 5.4.
Also, switch to EAPI 8. Closes: https://github.com/gentoo/gentoo/pull/23276 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--sci-physics/geant4_vmc/Manifest1
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-5.4.ebuild82
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-9999.ebuild2
3 files changed, 84 insertions, 1 deletions
diff --git a/sci-physics/geant4_vmc/Manifest b/sci-physics/geant4_vmc/Manifest
index ddfb4b445a2e..921ae0a6fb92 100644
--- a/sci-physics/geant4_vmc/Manifest
+++ b/sci-physics/geant4_vmc/Manifest
@@ -1 +1,2 @@
DIST geant4_vmc-5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
+DIST geant4_vmc-5.4.tar.gz 7363185 BLAKE2B 3f1738a6d99d7cad1df1249a086b5257ff1d9c5c23657e12720b2d75ed61a96d6e45f2c964c471ba093d1c70fffb5b3df5a0d15fd7bdd54ab78a8f225649f0a1 SHA512 26b53c4b3a10943b9a5aa970dfc8c09b4086a385c6fea2a914bf8b020044032f9b73df7fd054185eba86f66ba50cd86372d0e874c0642bb3e357fba499fd7675
diff --git a/sci-physics/geant4_vmc/geant4_vmc-5.4.ebuild b/sci-physics/geant4_vmc/geant4_vmc-5.4.ebuild
new file mode 100644
index 000000000000..9126c02198df
--- /dev/null
+++ b/sci-physics/geant4_vmc/geant4_vmc-5.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="https://github.com/vmc-project/geant4_vmc"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="doc examples geant3 +g4root +mtroot vgm test"
+
+RDEPEND="
+ <sci-physics/geant-4.11[c++17,opengl,geant3?]
+ sci-physics/root:=[c++17,-vmc]
+ sci-physics/vmc:=[c++17]
+ vgm? ( sci-physics/vgm:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
+RESTRICT="
+ !examples? ( test )
+ !geant3? ( test )
+ !g4root? ( test )
+ !mtroot? ( test )
+ !test? ( test )
+ !vgm? ( test )"
+
+DOCS=(history README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_BUILD_MTRoot="$(usex mtroot)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc ; then
+ local dirs=(
+ source
+ $(usev g4root)
+ $(usev mtroot)
+ $(usev examples)
+ )
+ local d
+ for d in "${dirs[@]}"; do
+ pushd "${d}" > /dev/null || die
+ doxygen || die
+ popd > /dev/null || die
+ done
+ fi
+}
+
+src_test() {
+ cd examples || die
+ ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=(doc/.)
+ einstalldocs
+}
diff --git a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
index e5a8d12edb26..972ea0ba5344 100644
--- a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake