summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:24:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:46 +0100
commitd3ab063bbec541e45b197730701b8994bc8cc433 (patch)
treeee900394b8313ad831be50586740f6a11dd9c1f7
parentdev-python/rjsmin: Migrate to PEP517 build (diff)
downloadgentoo-d3ab063b.tar.gz
gentoo-d3ab063b.tar.bz2
gentoo-d3ab063b.zip
dev-python/rope: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rope/rope-0.22.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rope/rope-0.22.0-r1.ebuild b/dev-python/rope/rope-0.22.0-r1.ebuild
new file mode 100644
index 000000000000..f461efcc5f5f
--- /dev/null
+++ b/dev-python/rope/rope-0.22.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}