summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-02 07:30:35 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-02 07:41:15 +0200
commitd3b1a9c78135d3ca8ebccef9d1e563bce77e8a99 (patch)
treefc556ba6079041b51960f9d91f147c92addb6504
parentdev-ruby/sprockets: add ruby24 (diff)
downloadgentoo-d3b1a9c7.tar.gz
gentoo-d3b1a9c7.tar.bz2
gentoo-d3b1a9c7.zip
dev-ruby/activesupport: add rails 5.0.4
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.0.4.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 18d357ff7955..fe8bb2208ac8 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -4,4 +4,5 @@ DIST rails-5.0.0.1.tgz 6139334 SHA256 3cbbe71d80c2813dde0d2bfa61aea57c8e6a1a3b2a
DIST rails-5.0.1.tgz 6026895 SHA256 7ee54f0175a7738e7c169fa8dc2e4ee30ba8407768804aaa56a6889525315f4e SHA512 d5c25b284b24399f81a5a8aec9c4b581d2caeff6d1f73b71dab2a50b8f55b4a86c1d723f0bae9b40bdb3d949e3d5eb65b7522bf9ca316676cafdd2cf648abb33 WHIRLPOOL 142190cc4f8edafdc39cdbab2586127815e145f4d4fa5a89f3c9b2377e70bc29f6d410359c0498fe1c83c8f811b64884ae0d7e06b20d8ffb5ec44c6b66cde49b
DIST rails-5.0.2.tgz 6034813 SHA256 4ca4ab89c06776f959edde03833f83be05002db5a1028e9276d45db6a2358cd4 SHA512 bb82bd33e47b875f3a9bc6d833492b89fbf86afff27049f1f8710a406452dee1cb5b287b0e19d6b2f45ee59181b28425916746d1b6ef835029944aff4bcf255b WHIRLPOOL 1e4bda983d10aace2b49df133b76f8fdd9246ce071b09dd00a6aa72c2f2a4fb758214427520170ca6f819ac602199087bf993debd6275e5b23184b5e7f46bff7
DIST rails-5.0.3.tgz 6041420 SHA256 0c16f63af96529c1e3d2b4476031bd024ae403322fe78e80e188a422412dc582 SHA512 5a25747507d2a8e1d2a19ce14c77a80c4f9bd5751fb343c3f405b8d9ec170d11fb866ebfedf6b850b6750399015631ab1551e6f78e097c6514061462a05e88f3 WHIRLPOOL 25fd8473a4eed2f007b99e22cb7ccf834780d4f21478a0818c44bea525f4c839610bab2b52ae5087a881f8d5519b78616f4e53e6a21f7d6f9270c0ddf648a2a5
+DIST rails-5.0.4.tgz 6041948 SHA256 50f64f8c1d083d22a652ce4d594b38674a502b89ed7b913ebb9f1dce6984a32e SHA512 9a99d506606f2901f8b4afcfa8cc92e7d122b0879c619a539aee52df5b8926e6dca98e0eb14234f810b8a73730c3c051985e13ab0bab5f52cd8c11a0b112c44d WHIRLPOOL 842f3dfd691c7904804be128e4acf555076b96e5dbb8d874918a6492991f67c31faf8d4a5410969eadcef1166035f64c1fed6e8ae4f9f2b808600ea729a15808
DIST rails-5.1.1.tgz 6124695 SHA256 a09bfa7d2917865778af70dff8bd57fe01820eca0228cff85de581ee17e9adf2 SHA512 fd62506eac440f1ad9b37f20c7c712733440bc2ee676390c02e3bd50b912fe0fd53e8092c23664d47818ee62583568c6e20d2bfd5eff6d22a005289bb3bb258f WHIRLPOOL a23d6644126e6e01481c48c7089208a535188b5b32ad67cb69db36ac2044ee35bd95d4012076d7f12666aed2cbe984c75c3555889923710f10b1b91c150ccc73
diff --git a/dev-ruby/activesupport/activesupport-5.0.4.ebuild b/dev-ruby/activesupport/activesupport-5.0.4.ebuild
new file mode 100644
index 000000000000..32482f660ae7
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.0.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-0.7:* <dev-ruby/i18n-1:*
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test not working within portage
+ sed -i -e '/test_messing_with_either_encrypted_values_causes_failure/askip "gentoo"' test/message_encryptor_test.rb || die
+
+ # Avoid tests failing since test_order cattr is also seen as a test
+ # method
+ rm -f test/xml_mini/libxml{,sax}_engine_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions. This might be
+ # fixed upstream in 7bd41994480c17db71fdc07e3447ade929eaa386
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid tests which make network connections
+ rm -f test/multibyte_{grapheme_break,normalization}_conformance_test.rb || die
+}