summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-02 10:04:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-02 10:51:25 +0200
commitd3b6b807e408c7a463e27a005e4217e15ff10715 (patch)
tree90cdd5cf62ff16e8b2e24fff09ed4405ce234f45
parentdev-python/hypothesis: Bump to 6.8.4 (diff)
downloadgentoo-d3b6b807.tar.gz
gentoo-d3b6b807.tar.bz2
gentoo-d3b6b807.zip
dev-python/fonttools: Bump to 4.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.22.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 8213b0ea047c..3b170aa9c575 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1 +1,2 @@
DIST fonttools-4.21.1.tar.gz 2531249 BLAKE2B 7f507f85061c67da0003ed2c4f685b22ccf0e6c5067adb934772ef0832656bbe092d1282b30b5a40071cd3a3219f5cfd810e06e9cd3f85ddd8fa93538134c943 SHA512 8c54809ab9f39e34f482ee6b17dbf8b309e8bfa0bde783e24195c1f2949ded64591c5e79565136ec8492c0095d593db20779d3f28b933f8e40e54b610130e0f4
+DIST fonttools-4.22.0.tar.gz 2544600 BLAKE2B 685da467c40fc7cffe2b33b08da53e5bd148c5190efdc8d08e2c66ef06e67b5e26ec5fa090334b9ef427b1a005c6386b0f78b978d376c7daee7f4d540faa21c7 SHA512 06db054ce488d0291f876b05b5dd09a772a702f1d45b97c1ba46d02e01fe59f7c63e268fff958baa4076c1ce72f450384e473263250c1617791d78c0e311710d
diff --git a/dev-python/fonttools/fonttools-4.22.0.ebuild b/dev-python/fonttools/fonttools-4.22.0.ebuild
new file mode 100644
index 000000000000..a132b8324f4c
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.22.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}