summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-29 04:26:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-29 05:27:28 +0200
commitd3bc1a8050a110abd7a0b208bed6a7879114e5e4 (patch)
tree7dfb6e966d573fcd90dc010599fc8f42d7d93622
parentdev-python/pyqtgraph: Bump to 0.13.7 (diff)
downloadgentoo-d3bc1a8050a110abd7a0b208bed6a7879114e5e4.tar.gz
gentoo-d3bc1a8050a110abd7a0b208bed6a7879114e5e4.tar.bz2
gentoo-d3bc1a8050a110abd7a0b208bed6a7879114e5e4.zip
dev-python/pytest-xdist: Bump to 3.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.6.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 483e783436fd..014754a9d137 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xdist-3.5.0.tar.gz 78977 BLAKE2B 94feaa236728688a993ed89825f4ccd67abd7a520d235790bbfc629173e5918695ac500d04de642f07d323325972512e3ad95f0ae18a9ea239da8c2f167ab1a5 SHA512 1b6a896c6c69c110d1f3aa634740ffced570bbb788b3474687fef20147a5480a8681886b04db0413f7db68db546236f9a7f37e1592a74d1145f6eb6d876216ca
DIST pytest_xdist-3.6.0.tar.gz 83818 BLAKE2B e15935799675014a01524b850106c29b1e43efcdc965c5695ae727ba4c12af446dbaec662eb66022b3e553e311d456859e90c7cfb0f7b4d9d0f28c3184e2901a SHA512 d623d31fa3f441c7ac56b7740bdd205933b90c9784ae1bcbac185bdc2920f1a27fa51fa6e1b75392a3ae13a62c51e168925ce3040cc1f0d22e8d9906faebbc2e
+DIST pytest_xdist-3.6.1.tar.gz 84060 BLAKE2B 01392bc1f5a1587f609fc0246235457ab92ca40b3c34c660c117fae1c2b8b98dc0cde345f42951d69c3b58732e0094c7618ed570a6e3ca41165e93e2d8cf9e84 SHA512 583a78d0adc05d81458bbdd5832c239581c0fcd9cad9edfd16fa78009c005c15bffec7ed074d9e18f1542393f62d9ccb2c9e0a96d825e9cff1faec123545a2a3
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.6.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.6.1.ebuild
new file mode 100644
index 000000000000..602cb721af56
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-3.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xdist/
+ https://github.com/pytest-dev/pytest-xdist/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/execnet-2.1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail
+
+ epytest -o tmp_path_retention_count=1
+}