summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-23 04:01:48 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-27 11:08:38 -0500
commitd3bce60414f651b5044d8276ad9c3e3f5afe9e15 (patch)
tree7df607f7c18bbf2f965db8c5962b575d28553c4c
parentdev-python/ttystatus: bump. (diff)
downloadgentoo-d3bce60414f651b5044d8276ad9c3e3f5afe9e15.tar.gz
gentoo-d3bce60414f651b5044d8276ad9c3e3f5afe9e15.tar.bz2
gentoo-d3bce60414f651b5044d8276ad9c3e3f5afe9e15.zip
dev-scheme/guile: fix guile-2.0.0 building with clang
Also update to EAPI=6
-rw-r--r--dev-scheme/guile/files/guile-2.0.0-clang-apicontrol-texi.patch12
-rw-r--r--dev-scheme/guile/guile-2.0.0.ebuild31
2 files changed, 24 insertions, 19 deletions
diff --git a/dev-scheme/guile/files/guile-2.0.0-clang-apicontrol-texi.patch b/dev-scheme/guile/files/guile-2.0.0-clang-apicontrol-texi.patch
new file mode 100644
index 000000000000..cbd3f466120d
--- /dev/null
+++ b/dev-scheme/guile/files/guile-2.0.0-clang-apicontrol-texi.patch
@@ -0,0 +1,12 @@
+--- a/doc/ref/api-control.texi 2016-06-23 03:35:29.973976657 -0500
++++ b/doc/ref/api-control.texi 2016-06-23 03:33:36.589969005 -0500
+@@ -1492,8 +1492,8 @@
+ @deftypefnx {C Function} void scm_wrong_type_arg (char *@var{subr}, int @var{argnum}, SCM @var{bad_value})
+ @deftypefnx {C Function} void scm_wrong_type_arg_msg (char *@var{subr}, int @var{argnum}, SCM @var{bad_value}, const char *@var{expected})
+ @deftypefnx {C Function} void scm_memory_error (char *@var{subr})
+-Throw an error with the various keys described above.
+ @deftypefnx {C Function} void scm_misc_error (const char *@var{subr}, const char *@var{message}, SCM @var{args})
++Throw an error with the various keys described above.
+
+ In @code{scm_wrong_num_args}, @var{proc} should be a Scheme symbol
+ which is the name of the procedure incorrectly invoked. The other
diff --git a/dev-scheme/guile/guile-2.0.0.ebuild b/dev-scheme/guile/guile-2.0.0.ebuild
index 59f04c6a8bbd..e5204ae2e979 100644
--- a/dev-scheme/guile/guile-2.0.0.ebuild
+++ b/dev-scheme/guile/guile-2.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
-inherit eutils flag-o-matic elisp-common
+EAPI=6
+inherit flag-o-matic elisp-common
DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
@@ -29,11 +29,15 @@ DEPEND="${RDEPEND}
SLOT="2"
MAJOR="2.0"
+PATCHES=(
+ "${FILESDIR}/${P}-clang-apicontrol-texi.patch"
+ )
+
src_configure() {
# see bug #178499
filter-flags -ftree-vectorize
- #will fail for me if posix is disabled or without modules -- hkBst
+ # will fail for me if posix is disabled or without modules -- hkBst
econf \
--disable-error-on-warning \
--disable-static \
@@ -51,26 +55,15 @@ src_configure() {
# EMACS=no
}
-src_compile() {
- emake || die "make failed"
-
- # Above we have disabled the build system's Emacs support;
- # for USE=emacs we compile (and install) the files manually
- # if use emacs; then
- # cd emacs
- # make
- # elisp-compile *.el || die
- # fi
-}
-
src_install() {
- einstall || die "install failed"
+ default
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS || die
+ dodoc GUILE-VERSION HACKING
# texmacs needs this, closing bug #23493
dodir /etc/env.d
- echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" > "${ED}"/etc/env.d/50guile
+ echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" \
+ > "${ED}"/etc/env.d/50guile || die
# necessary for registering slib, see bug 206896
keepdir /usr/share/guile/site