summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-31 16:49:31 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-10-31 16:56:27 +0100
commitd3d68c84070e84997faf0c1d98b0eb6762f8e331 (patch)
treea3e1b32a05aa7a3772260dda07a459d77e2e8363
parentdev-libs/leatherman: 1.9.0 bump (diff)
downloadgentoo-d3d68c84070e84997faf0c1d98b0eb6762f8e331.tar.gz
gentoo-d3d68c84070e84997faf0c1d98b0eb6762f8e331.tar.bz2
gentoo-d3d68c84070e84997faf0c1d98b0eb6762f8e331.zip
www-client/firefox: force stderr for ewarn in llvm_check_deps()
Closes: https://bugs.gentoo.org/695668 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-68.2.0.ebuild19
-rw-r--r--www-client/firefox/firefox-70.0.ebuild19
2 files changed, 18 insertions, 20 deletions
diff --git a/www-client/firefox/firefox-68.2.0.ebuild b/www-client/firefox/firefox-68.2.0.ebuild
index b51a15732d01..7c5b0d66a9e5 100644
--- a/www-client/firefox/firefox-68.2.0.ebuild
+++ b/www-client/firefox/firefox-68.2.0.ebuild
@@ -189,37 +189,36 @@ fi
llvm_check_deps() {
if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
- ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
- if use pgo ; then
- if ! has usersandbox $FEATURES ; then
- eerror "You must enable usersandbox as X server can not run as root!"
- fi
- fi
-
if use clang ; then
if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
- ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
if use pgo ; then
if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
- ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi
fi
- # <EAPI 7 workaround, #695668
einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
}
pkg_setup() {
moz_pkgsetup
+ if use pgo ; then
+ if ! has usersandbox $FEATURES ; then
+ die "You must enable usersandbox as X server can not run as root!"
+ fi
+ fi
+
# Avoid PGO profiling problems due to enviroment leakage
# These should *always* be cleaned up anyway
unset DBUS_SESSION_BUS_ADDRESS \
diff --git a/www-client/firefox/firefox-70.0.ebuild b/www-client/firefox/firefox-70.0.ebuild
index c4e0acf07889..e043eb802103 100644
--- a/www-client/firefox/firefox-70.0.ebuild
+++ b/www-client/firefox/firefox-70.0.ebuild
@@ -192,37 +192,36 @@ fi
llvm_check_deps() {
if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
- ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
- if use pgo ; then
- if ! has usersandbox $FEATURES ; then
- eerror "You must enable usersandbox as X server can not run as root!"
- fi
- fi
-
if use clang ; then
if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
- ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
if use pgo ; then
if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
- ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+ ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi
fi
- # <EAPI 7 workaround, #695668
einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
}
pkg_setup() {
moz_pkgsetup
+ if use pgo ; then
+ if ! has usersandbox $FEATURES ; then
+ die "You must enable usersandbox as X server can not run as root!"
+ fi
+ fi
+
# Avoid PGO profiling problems due to enviroment leakage
# These should *always* be cleaned up anyway
unset DBUS_SESSION_BUS_ADDRESS \