summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-03 21:31:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-03 21:31:34 +0200
commitd3f81c760e23fba9350de794200bf373673d2c71 (patch)
tree134e8585a53097ff8faa5a9e5d6bae375b667138
parentdev-python/jupyter_server: Stabilize 1.19.1 ALLARCHES, #879451 (diff)
downloadgentoo-d3f81c76.tar.gz
gentoo-d3f81c76.tar.bz2
gentoo-d3f81c76.zip
dev-python/sentry-sdk: drop 1.9.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index c5234ec3ea33..bf45ad897d19 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,2 @@
DIST sentry-sdk-1.10.1.gh.tar.gz 292186 BLAKE2B 03181c0118294d4221b176b1e4fd38b4b2147a3a1b6eae709153f92717da77e889d17e715ad1795c8d9bdf24ed2ca5718a88b4f3fa25d240ec8e5804d1041a56 SHA512 135dff6db284439812d74b54f301ba0ce25444f71ad0b7d3ff8869399dba97affa40673fd306960bc6665118e0aabd1a3420976effc9a501d51d9f2174d615f4
DIST sentry-sdk-1.9.10.gh.tar.gz 282661 BLAKE2B dbecfafafebb52f288ff977dc39b7268c0cd7fc78a643139b9baf9345eb216842bad426e860914dad325096306dc515bf48ddfb26f524c95c718787ecadce3e1 SHA512 293f38335692fe6ec215d470b436d2a8ae49ac8471722c555405e920a41d2d591682c956bb01ad43bb3705566353a878f8fabfe74248716e9cf5a2ea2c172649
-DIST sentry-sdk-1.9.9.gh.tar.gz 281232 BLAKE2B 8d1017644c2ae73c4e070f7b1b0a6807ab1d7a7655986bb9a4b457f72c98b3df0fd5f3af8722ea91e13911b1ce6d7234542af195a0b80ec5e9e939f5de3998f0 SHA512 613b504c9e0071657241c7724206d3e99f62fdc846cda98fa4830cf29eee24c8d2ae2abb265fab5d87f47d064d8aed60e105c2d2090fb24308e65b7e74e2974b
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild
deleted file mode 100644
index 680e0e88eaeb..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.9.9.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="
- https://sentry.io/
- https://github.com/getsentry/sentry-python/
- https://pypi.org/project/sentry-sdk/
-"
-SRC_URI="
- https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/flask/test_flask.py
- tests/integrations/django/test_basic.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # broken by rq-1.10.1 (optional dep)
- tests/integrations/rq/test_rq.py
- # fastapi is not packaged
- tests/integrations/asgi/test_fastapi.py
- # TODO
- tests/integrations/bottle
- # requires python-multipart (TODO: package it)
- tests/integrations/starlette
-)
-
-EPYTEST_DESELECT=(
- # hangs
- 'tests/test_transport.py::test_transport_works'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/asgi/test_asgi.py::test_websocket
- tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
- tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- # TODO
- tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
- tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
-)