summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-06-04 21:27:28 +1000
committerSam James <sam@gentoo.org>2022-06-04 22:13:28 +0100
commitd4053942550ffe073b63307a40d78de7d9c36e26 (patch)
tree12cfaf19ef875fc6440ee586e46f4b6161b2c33c
parentdev-perl/Sereal-Encoder: add pkgconfig BDEPEND (diff)
downloadgentoo-d4053942.tar.gz
gentoo-d4053942.tar.bz2
gentoo-d4053942.zip
x11-wm/fvwm3: Fix breaking builds
- Bug in fvwm3-1.0.4-htmldoc patch - Upstream bug with `./configure ... --disable-xft` (truetype USE flag) - Upstream bug with `./configure ... --disable-png` (png USE flag) Closes: https://bugs.gentoo.org/849596 Closes: https://bugs.gentoo.org/849668 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/25748 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-wm/fvwm3/Manifest2
-rw-r--r--x11-wm/fvwm3/files/fvwm3-1.0.4-htmldoc.patch29
-rw-r--r--x11-wm/fvwm3/fvwm3-1.0.4.ebuild32
-rw-r--r--x11-wm/fvwm3/fvwm3-9999.ebuild32
4 files changed, 30 insertions, 65 deletions
diff --git a/x11-wm/fvwm3/Manifest b/x11-wm/fvwm3/Manifest
index 6ba89565ed08..8fbcc853d95b 100644
--- a/x11-wm/fvwm3/Manifest
+++ b/x11-wm/fvwm3/Manifest
@@ -1,3 +1 @@
-DIST fvwm3-1.0.4-deps.tar.xz 2847880 BLAKE2B 245a5fa7846ffd74679ecd280b7f31cdcc58dfb765923750b22905caecdea0a1b2a322eeecc8133996414be37026de9f859222b78d93ed6c974005456ee953d1 SHA512 c93e5d4706a6261d8ebafcb5d2576377d79dfb693cc2b4a7608c3657b1c612b7c17a2554a6cef30c80ed5ffc9d0efd16f9adc33b2a9b906ece812fdf4fa8ab86
DIST fvwm3-1.0.4.tar.gz 4691719 BLAKE2B 4ce93b1a2d110b570b5fc8b253f9ff8ea1f44e5470c6e1bc136a53ebe53a23abe3d075bf351fca54ac110ea5731f9b44c59c83186d320e7509bf26e5144436ca SHA512 b72a1ebeba7c55214603fd43ea439f7283b3c79e39d2671a67b9512c67dcea111377eab2131ed0b18a72f6b772b0d048abe08f52565708367465ed9bb14e85f6
-DIST fvwm3-9999-deps.tar.xz 3712984 BLAKE2B 389f70dbadbe2fe6accd4793ed71e17cb2ff2f72e318e1744204344902145e5050ace5379f4de89991907199b7b354a9690e6546382d1eedfcdb676b28f1ff13 SHA512 444b1ea17b31d477ae12b4ef84a9f5fb85aae1158aead1bc3a4d8e96a18dde6a13e41e3e3552bd652eb58fe42958ad45791a1d4ef70242e9d6d80060067cef86
diff --git a/x11-wm/fvwm3/files/fvwm3-1.0.4-htmldoc.patch b/x11-wm/fvwm3/files/fvwm3-1.0.4-htmldoc.patch
index 67abc9febfa4..ef277e902faa 100644
--- a/x11-wm/fvwm3/files/fvwm3-1.0.4-htmldoc.patch
+++ b/x11-wm/fvwm3/files/fvwm3-1.0.4-htmldoc.patch
@@ -1,7 +1,7 @@
-This patch enables HTML documentation output
+This patch enables html documentation output for fvwm3 1.0.4
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
-@@ -1,29 +1,39 @@
+@@ -1,40 +1,59 @@
docdir = @FVWM_DOCDIR@
-MODULE_ADOCS = $(wildcard fvwm3/fvwm3.adoc bin/*.adoc modules/*.adoc)
+DOC_SRC = $(wildcard fvwm3/fvwm3.adoc bin/*.adoc modules/*.adoc)
@@ -21,7 +21,7 @@ This patch enables HTML documentation output
-docs: $(BUILD_MANS)
+all: man html
+
-+man: $(BUILD_MANS)
++man: $(BUILD_MANS)
+
+html: $(BUILD_HTML)
@@ -32,7 +32,8 @@ This patch enables HTML documentation output
distclean-local: clean
if FVWM_BUILD_MANDOC
- QUIET_ASCIIDOC = @echo ' ' DOC ' ' $@'.1';
+-QUIET_ASCIIDOC = @echo ' ' DOC ' ' $@'.1';
++QUIET_ASCIIDOC = @echo ' ' DOC ' ' $@;
-%: %.adoc
+%.1: %.adoc
@@ -48,23 +49,25 @@ This patch enables HTML documentation output
install-data-local:
install -d -m 755 $(DESTDIR)$(mandir)/man1/
-@@ -31,10 +41,19 @@ install-data-local:
+ @for i in $(notdir $(BUILD_MANS)); do \
NAME=`basename "$$i" | "$(SED)" -e "${transform}"`; \
- install -m 644 "man1/$$NAME.1" $(DESTDIR)$(mandir)/man1/; \
- done
+- install -m 644 "man1/$$NAME.1" $(DESTDIR)$(mandir)/man1/; \
++ install -m 644 "man1/$$NAME" $(DESTDIR)$(mandir)/man1/; \
++ done
+ install -d -m 755 $(DESTDIR)$(mandir)/html/
+ @for i in $(notdir $(BUILD_HTML)); do \
+ NAME=`basename "$$i" | "$(SED)" -e "${transform}"`; \
-+ install -m 644 "html/$$NAME.html" $(DESTDIR)$(mandir)/html/; \
-+ done
++ install -m 644 "html/$$NAME" $(DESTDIR)$(mandir)/html/; \
+ done
uninstall-local:
@for i in $(notdir $(BUILD_MANS)); do \
NAME=`basename "$$i" | "$(SED)" -e "${transform}"`; \
- rm -f "$(DESTDIR)$(mandir)/man1/$$NAME.1"; \
- done
+- rm -f "$(DESTDIR)$(mandir)/man1/$$NAME.1"; \
++ rm -f "$(DESTDIR)$(mandir)/man1/$$NAME"; \
++ done
+ @for i in $(notdir $(BUILD_HTML)); do \
+ NAME=`basename "$$i" | "$(SED)" -e "${transform}"`; \
-+ rm -f "$(DESTDIR)$(mandir)/html/$$NAME.html"; \
-+ done
++ rm -f "$(DESTDIR)$(mandir)/html/$$NAME"; \
+ done
endif
diff --git a/x11-wm/fvwm3/fvwm3-1.0.4.ebuild b/x11-wm/fvwm3/fvwm3-1.0.4.ebuild
index cbafa1cafe1d..b8246aa3ce60 100644
--- a/x11-wm/fvwm3/fvwm3-1.0.4.ebuild
+++ b/x11-wm/fvwm3/fvwm3-1.0.4.ebuild
@@ -19,8 +19,6 @@ else
KEYWORDS="~amd64"
fi
-SRC_URI+=" https://gitlab.com/Matt.Jolly/fvwm3-go-deps/-/raw/${PV}/${P}-deps.tar.xz?inline=false -> ${P}-deps.tar.xz"
-
LICENSE="GPL-2+ FVWM
go? (
Apache-2.0
@@ -30,7 +28,7 @@ LICENSE="GPL-2+ FVWM
SLOT="0"
-IUSE="bidi debug doc go netpbm nls perl png readline rplay stroke svg tk truetype vanilla lock"
+IUSE="bidi debug doc go netpbm nls perl readline rplay stroke svg tk vanilla lock"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}"
@@ -51,9 +49,11 @@ BDEPEND="
RDEPEND="${PYTHON_DEPS}
${COMMON_DEPEND}
!x11-wm/fvwm
+ dev-lang/perl
dev-libs/glib:2
dev-libs/libevent:=
- dev-lang/perl
+ media-libs/fontconfig
+ media-libs/libpng:=
sys-libs/zlib
x11-libs/libICE
x11-libs/libSM
@@ -64,6 +64,7 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/libXdmcp
x11-libs/libXext
x11-libs/libXfixes
+ x11-libs/libXft
x11-libs/libXpm
x11-libs/libXrandr
x11-libs/libXrender
@@ -76,7 +77,6 @@ RDEPEND="${PYTHON_DEPS}
>=dev-perl/X11-Protocol-0.56
)
)
- png? ( media-libs/libpng:= )
readline? (
sys-libs/ncurses:=
sys-libs/readline:=
@@ -87,10 +87,6 @@ RDEPEND="${PYTHON_DEPS}
gnome-base/librsvg:2
x11-libs/cairo
)
- truetype? (
- media-libs/fontconfig
- x11-libs/libXft
- )
userland_GNU? ( sys-apps/debianutils )"
DEPEND="${COMMON_DEPEND}
@@ -106,26 +102,12 @@ if [[ ${PV} == 9999 ]]; then
)
fi
-src_unpack() {
- if [[ ${PV} == 9999 ]]; then
- einfo "The branch ${EGIT_BRANCH} will be installed."
- git-r3_src_unpack
- else
- unpack "${P}".tar.gz
- fi
- unpack "${P}"-deps.tar.xz
- mv go-mod ${P}/bin/FvwmPrompt/ || die
-}
-
src_prepare() {
default
if use doc; then
eapply "${FILESDIR}/${P}-htmldoc.patch"
fi
- sed -i '/^@FVWM_BUILD_GOLANG_TRUE@GOBUILD = $(GOCMD) build/s/$/ -mod=mod/' \
- bin/FvwmPrompt/Makefile.in || die "Updating go build paramaters failed."
-
eautoreconf
}
@@ -151,10 +133,10 @@ src_configure() {
$(use_enable nls)
$(use_enable nls iconv)
$(use_enable perl perllib)
- $(use_enable png)
$(use_with readline readline-library)
$(use_enable svg rsvg)
- $(use_enable truetype xft)
+ --enable-png
+ --enable-xft
--docdir=/usr/share/doc/${P}
)
diff --git a/x11-wm/fvwm3/fvwm3-9999.ebuild b/x11-wm/fvwm3/fvwm3-9999.ebuild
index cbafa1cafe1d..368e25548404 100644
--- a/x11-wm/fvwm3/fvwm3-9999.ebuild
+++ b/x11-wm/fvwm3/fvwm3-9999.ebuild
@@ -19,8 +19,6 @@ else
KEYWORDS="~amd64"
fi
-SRC_URI+=" https://gitlab.com/Matt.Jolly/fvwm3-go-deps/-/raw/${PV}/${P}-deps.tar.xz?inline=false -> ${P}-deps.tar.xz"
-
LICENSE="GPL-2+ FVWM
go? (
Apache-2.0
@@ -30,7 +28,7 @@ LICENSE="GPL-2+ FVWM
SLOT="0"
-IUSE="bidi debug doc go netpbm nls perl png readline rplay stroke svg tk truetype vanilla lock"
+IUSE="bidi debug doc go netpbm nls perl readline rplay stroke svg tk vanilla lock"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}"
@@ -51,9 +49,11 @@ BDEPEND="
RDEPEND="${PYTHON_DEPS}
${COMMON_DEPEND}
!x11-wm/fvwm
+ dev-lang/perl
dev-libs/glib:2
dev-libs/libevent:=
- dev-lang/perl
+ media-libs/fontconfig
+ media-libs/libpng:=
sys-libs/zlib
x11-libs/libICE
x11-libs/libSM
@@ -64,6 +64,7 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/libXdmcp
x11-libs/libXext
x11-libs/libXfixes
+ x11-libs/libXft
x11-libs/libXpm
x11-libs/libXrandr
x11-libs/libXrender
@@ -76,7 +77,7 @@ RDEPEND="${PYTHON_DEPS}
>=dev-perl/X11-Protocol-0.56
)
)
- png? ( media-libs/libpng:= )
+ media-libs/libpng:=
readline? (
sys-libs/ncurses:=
sys-libs/readline:=
@@ -87,10 +88,6 @@ RDEPEND="${PYTHON_DEPS}
gnome-base/librsvg:2
x11-libs/cairo
)
- truetype? (
- media-libs/fontconfig
- x11-libs/libXft
- )
userland_GNU? ( sys-apps/debianutils )"
DEPEND="${COMMON_DEPEND}
@@ -106,26 +103,12 @@ if [[ ${PV} == 9999 ]]; then
)
fi
-src_unpack() {
- if [[ ${PV} == 9999 ]]; then
- einfo "The branch ${EGIT_BRANCH} will be installed."
- git-r3_src_unpack
- else
- unpack "${P}".tar.gz
- fi
- unpack "${P}"-deps.tar.xz
- mv go-mod ${P}/bin/FvwmPrompt/ || die
-}
-
src_prepare() {
default
if use doc; then
eapply "${FILESDIR}/${P}-htmldoc.patch"
fi
- sed -i '/^@FVWM_BUILD_GOLANG_TRUE@GOBUILD = $(GOCMD) build/s/$/ -mod=mod/' \
- bin/FvwmPrompt/Makefile.in || die "Updating go build paramaters failed."
-
eautoreconf
}
@@ -151,10 +134,9 @@ src_configure() {
$(use_enable nls)
$(use_enable nls iconv)
$(use_enable perl perllib)
- $(use_enable png)
$(use_with readline readline-library)
$(use_enable svg rsvg)
- $(use_enable truetype xft)
+ --enable-png
--docdir=/usr/share/doc/${P}
)