summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 08:08:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 09:00:19 +0200
commitd406c61eed313ccdec2136683590a540c24204fc (patch)
tree1af06ada59b2b98d65d6b1a5de1c7629a918e044
parentdev-python/botocore: Bump to 1.17.49 (diff)
downloadgentoo-d406c61e.tar.gz
gentoo-d406c61e.tar.bz2
gentoo-d406c61e.zip
dev-python/boto3: Bump to 1.14.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.49.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index ae510e174aac..691cb9f17199 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.14.23.tar.gz 299581 BLAKE2B 57cbb3fbd9a84f334b5874ca96490cb0269bb79f3fd2b50d4c51efcfadaa41b2e11853266ba12544b77999fa85fefb0bdf84d924667c4092b3deb72f41e33a21 SHA512 263b2abf3c220d3fb3d7acf4cd87266c11d3dcd5d7ffcafb0aab128b1e324d6f99c44de8abfb621b153b5fc51b9823b6b79ea5c529f6c59c548c900015bcdb5e
DIST boto3-1.14.31.tar.gz 300720 BLAKE2B 9dbd002e299c629f28037572c615a00612c80773006c344797d0ad56c81c240b56bfc56e8ffe52e3b404c77a56318532aadfa2d008c254e70f7bfa91e40b7e1a SHA512 e3fe0041bbdc67affcf5d5272c26aa14ef0fa546af2efb99187311bee23531181ab1f1ebc69f2c3ed8250140642f4402334ebbc9acbf422641fa6abed5d5815f
DIST boto3-1.14.46.tar.gz 301815 BLAKE2B e389e7e0cd9ed0907fd13a948bf37e00040e32029d7720f5a720c8c9cb3cf1fb157bb665032b4ba594b3b5f50129088f26f004535fc4f8fe72f32ab0be6ce9b9 SHA512 aa1aa0155fcaaaddcfc24697211e8f5a69eab1282a185f0cb76b02d63d1426c02ca3be71be980214484a351159f6bcc34c3422cd11b9a556d67802c01a06aed0
+DIST boto3-1.14.49.tar.gz 301978 BLAKE2B ab27aab54b7e1b531ae063e3a84691820208d5d229664d07aaba4c184d5344eb2a620bd2cf4cd4dc4555cf014926c56c89ee29a9832d7ede4fa46b025914a135 SHA512 bc66702f869cb41c6c6dc7d6f82eb09c962122e108d02daf2c4ee408b7a805193f2f4f9af0c5c96775c8a79975142d1154a32c2fe86b0c6aacd18617ff2934c8
diff --git a/dev-python/boto3/boto3-1.14.49.ebuild b/dev-python/boto3/boto3-1.14.49.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.49.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}