summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-08-25 20:40:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-08-25 21:05:42 +0200
commitd40a2975fb12395383223711e494e331c15f4a45 (patch)
tree590259a370335294d05ef7f7260fe4cb046b0fb5
parentdev-db/postgresql: stable 9.6.10 for ppc64, bug #664332 (diff)
downloadgentoo-d40a2975.tar.gz
gentoo-d40a2975.tar.bz2
gentoo-d40a2975.zip
net-libs/nghttp2: Bump to version 1.32.1
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.32.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 9a4ac72976a3..92ccf62a658f 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.29.0.tar.xz 1544736 BLAKE2B 1708d2c787e27d722aec27890a21e752a9fe66cdcff481615ac0bd9dcc92099946d9e5563a70137029dec54f8cc4244ef22813e0c2010572cd070ff272120bdb SHA512 a518ff1dcc9ae93f8228f4fa9110b9cbc460260a794d455530218c66317c6b96a5b14971aff25428e37326b5ce9f4d8480eefe6fcba17af23efa4ebceb56f23e
DIST nghttp2-1.31.1.tar.xz 1545400 BLAKE2B 1d1a0982dc36928fe031c26d7adeca3364e0efbef43a7a2e01701614e128c3ab307321fc3e3166f09e71f002bd14d1ad5caaf3242502cbe4e71285591d8f2977 SHA512 e0f5b345b6d794b21fa04bc0c7125f24a877074538ad746451d4a293eb22f1afb9e0e619c69b84f0fc2142a925044a19976af4cffb8426358e95e7d9715d5a4f
DIST nghttp2-1.32.0.tar.xz 1548528 BLAKE2B 1a1d031fc23ac14236c58a84aa94ee255646d36c9c631000b5d48e39c9fbc16e1b28d82e40bfc96d0fb9e2aa6982ed6bff77bcecdacf220ba8dea0b86d92bcab SHA512 ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e
+DIST nghttp2-1.32.1.tar.xz 1548812 BLAKE2B a4c1f4f8d5070d1ddc5a5680d9fda28ad0b3ee6b1241b58b2be2b63026af249a1bcaf62c158c084061802ce93934dc5648e20c54887df330e07407d5879d1412 SHA512 477e6f4ccdba5c86436d554be819fd10a715896173029aa72f9c90c2ee64dbe20e2ff4cde614be3a7683dec9e0feaa21d124493ed5fc12ad4c63a37a83bad57c
diff --git a/net-libs/nghttp2/nghttp2-1.32.1.ebuild b/net-libs/nghttp2/nghttp2-1.32.1.ebuild
new file mode 100644
index 000000000000..f472f1d77c9e
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.32.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}