summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-15 21:01:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-15 22:55:51 +0300
commitd40e7117452fcecf891404e731a3cfb64cff71d5 (patch)
tree139d2044c525d5fb452965e8ca881696dc9a4af8
parentdev-python/pywavelets: add 1.4.0 (diff)
downloadgentoo-d40e7117.tar.gz
gentoo-d40e7117.tar.bz2
gentoo-d40e7117.zip
dev-python/loky: add 3.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/loky/Manifest1
-rw-r--r--dev-python/loky/loky-3.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index ddf2f8ca14a6..d899140a1fb4 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1 +1,2 @@
DIST loky-3.1.0.tar.gz 139211 BLAKE2B 32e95312c40d6f8d8f9fc8daf5a1e85f1b874cbb902a4885621983d84a5fa9da42f05ff7d5d6bf58cf04a320c04c6e698ff0105cdad9ddd3248a109cc71c9883 SHA512 8bf6b032bb4f770d89c8de93d95c5805fa90dae34f2754f14c3a9fe7860230e8ce8ea97e1b09fa2cdf67f8aecdbd6d1e47ae4fb746fb1c6912d2dd65033f5b6f
+DIST loky-3.3.0.gh.tar.gz 141130 BLAKE2B 35560dca81cf41e03b24c8be6e70952c19b88fc9794cb13d7c910ac67ec4554555233026a215c6f147dc1354ad11bc14117b4eb6455ba758b79ea6650dc01f62 SHA512 120f771c75fe8691a198c93a91bf683af3d32c1bcaf2fa3e9c439d16546bff9feb6ce203667bd6c4e06ac326500b7bd117948e4deea6f53b04682af1f8d65734
diff --git a/dev-python/loky/loky-3.3.0.ebuild b/dev-python/loky/loky-3.3.0.ebuild
new file mode 100644
index 000000000000..ec4771d80692
--- /dev/null
+++ b/dev-python/loky/loky-3.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="https://github.com/joblib/loky"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ )
+
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory
+}