summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-24 19:23:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-24 19:23:19 +0100
commitd4161fcd734dbad7cedb258b4ae412b8630961e9 (patch)
treea9f58f3f47c8675a405a44da8b9d891fdff4f1a1
parentprofiles/arch/ia64/use.mask: unmack USE+networkmanager (diff)
downloadgentoo-d4161fcd734dbad7cedb258b4ae412b8630961e9.tar.gz
gentoo-d4161fcd734dbad7cedb258b4ae412b8630961e9.tar.bz2
gentoo-d4161fcd734dbad7cedb258b4ae412b8630961e9.zip
games-emulation/dolphin: add USE=vulkan
Patch-by: Samuel BAUER Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild6
-rw-r--r--games-emulation/dolphin/metadata.xml1
2 files changed, 6 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 09ecec7709c5..b63534d242d3 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log lto profile pulseaudio +qt5 systemd upnp"
+IUSE="alsa bluetooth discord-presence doc +evdev ffmpeg log lto profile pulseaudio +qt5 systemd upnp vulkan"
RDEPEND="
dev-libs/hidapi:0=
@@ -130,6 +130,9 @@ src_prepare() {
l10n_find_plocales_changes "Languages/po/" "" '.po'
l10n_for_each_disabled_locale_do remove_locale
+
+ # About 50% compile-time speedup
+ use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
}
src_configure() {
@@ -146,6 +149,7 @@ src_configure() {
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_QT=$(usex qt5)
-DENABLE_SDL=OFF # not supported: #666558
+ -DENABLE_VULKAN=$(usex vulkan)
-DFASTLOG=$(usex log)
-DOPROFILING=$(usex profile)
-DUSE_DISCORD_PRESENCE=$(usex discord-presence)
diff --git a/games-emulation/dolphin/metadata.xml b/games-emulation/dolphin/metadata.xml
index 6c45a6966333..965b67caf1ee 100644
--- a/games-emulation/dolphin/metadata.xml
+++ b/games-emulation/dolphin/metadata.xml
@@ -9,6 +9,7 @@
<flag name="evdev">Enable evdev input support</flag>
<flag name="log">Increase logging output</flag>
<flag name="lto">Add support for link-time optimizations.</flag>
+ <flag name="vulkan">Enable support for Vulkan-based video backend.</flag>
</use>
<longdescription lang="en">
Dolphin is a Gamecube and Wii emulator. Most games run perfectly or with minor