summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-08-22 12:49:33 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-08-22 13:35:42 -0400
commitd419a789867813ca3c8dbd7693152c6ec162796c (patch)
tree48579c188c572ef90830efc07df1c12557148989
parentmail-mta/courier: drop 1.1.8-r2, 1.2.2, 1.2.2-r1, 1.2.3 (diff)
downloadgentoo-d419a789867813ca3c8dbd7693152c6ec162796c.tar.gz
gentoo-d419a789867813ca3c8dbd7693152c6ec162796c.tar.bz2
gentoo-d419a789867813ca3c8dbd7693152c6ec162796c.zip
dev-lang/php: add 8.2.9, drop 8.2.8-r2
* New upstream security release. * Bring back USE=ipv6. Despite what pkgcheck thinks, this entails significant code changes. * Fix LTO build (bug 866683). Bug: https://bugs.gentoo.org/866683 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-lang/php/Manifest2
-rw-r--r--dev-lang/php/php-8.2.9.ebuild (renamed from dev-lang/php/php-8.2.8-r2.ebuild)8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/php/Manifest b/dev-lang/php/Manifest
index f83a1f6d7d21..953b51fa13f4 100644
--- a/dev-lang/php/Manifest
+++ b/dev-lang/php/Manifest
@@ -7,4 +7,4 @@ DIST php-8.1.12.tar.xz 11747176 BLAKE2B 0505794826fb0fc92b04be5f7162af8aa92d782b
DIST php-8.1.16.tar.xz 11760948 BLAKE2B ac0d352dae05115197852092b9b3c0b5091528326806c70eb34e0aba6007f718e927e67045d65976cb2104e4737a475b2224d4f05ff89ddf8c3066e0240c38e1 SHA512 4515da38803272abfafb069d1684c66dbb5086987b148c48dd7d8acf8f5316d255cf321ec57d6fbffe914a35551a533446ac13c34bb7c984e0d109247e8e64da
DIST php-8.1.20.tar.xz 11793228 BLAKE2B ecdaf43278b69e039e5440b441a89d02ea53e8246515a89f430d7affbaefa3e1637a6830f91dc9062961719ba5bf7c56993f3b47db96b56c14111f77c74a3096 SHA512 d93767c6ff4d305c209e1a0fcb17f19b1d417fa872b002413ebe7883e93900c210e8f122410ac54da373b9d10dd2f522ea2bafc9b66214fb466314d64907a558
DIST php-8.1.21.tar.xz 11862320 BLAKE2B 51195859c23a3216247a66f39e76bf4679f0365d390f31c7dee7437f22f45cee4e4f4de8cf42706e030355d9ec66b471d61fafc1b30da2eb65b339d99ace93c7 SHA512 aeb62947e12646a530b6f61efe9350e4a3632d421ee0bec6a1d26dc2fd680c782e12cbad06496f2d4ffcddf5182aa3438c19a59b0d593fc43789271241ec0383
-DIST php-8.2.8.tar.xz 12034856 BLAKE2B c07bec5e9eeb74e611f7480da21b9bd2b2e101bf00fe909a62a52b62c2a44dde5760b151317b3c0d6fb13cc69e3d81397c1b09b46f410e9b935e2fc6bb5b131e SHA512 d1539010761aaa525e286cf012953a097556c61608505a2b1a83f78b40b7a1c3338f494c4cf34abda764c762c4b0bacb09ce9286236d2a356ee61121236b6bcf
+DIST php-8.2.9.tar.xz 12035468 BLAKE2B 8b537fbd080cbe1e2b627c34110f41a13549ad6bd118803214bfeba3bb8564eef0c1d0d2ad14a500efc488078cd0e521e3a883865b4a79c2c4213cad670e334c SHA512 26c53dc737d6144cc0a3ce9134f92f59eb29f62c44b7d6159b92a25bdb0fa80239d7f6b6b663adfe444e57e98b202381df9b35532f40168ea093ac56d4bced19
diff --git a/dev-lang/php/php-8.2.8-r2.ebuild b/dev-lang/php/php-8.2.9.ebuild
index 98c074915afd..e725e7b5c992 100644
--- a/dev-lang/php/php-8.2.8-r2.ebuild
+++ b/dev-lang/php/php-8.2.9.ebuild
@@ -34,7 +34,7 @@ IUSE="${IUSE} acl apparmor argon2 avif bcmath berkdb bzip2 calendar
cdb cjk +ctype curl debug
enchant exif ffi +fileinfo +filter firebird
+flatfile ftp gd gdbm gmp +iconv imap inifile
- intl iodbc +jit kerberos ldap ldap-sasl libedit lmdb
+ intl iodbc ipv6 +jit kerberos ldap ldap-sasl libedit lmdb
mhash mssql mysql mysqli nls
oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
readline selinux +session session-mm sharedmem
@@ -333,6 +333,11 @@ src_configure() {
$(use_enable threads zts)
)
+ if is-flagq -flto; then
+ # https://bugs.gentoo.org/866683
+ our_conf+=( --disable-gcc-global-regs )
+ fi
+
our_conf+=(
$(use_with apparmor fpm-apparmor)
$(use_with argon2 password-argon2 "${EPREFIX}/usr")
@@ -355,6 +360,7 @@ src_configure() {
$(use_with iconv iconv \
$(use elibc_glibc || use elibc_musl || echo "${EPREFIX}/usr"))
$(use_enable intl)
+ $(use_enable ipv6)
$(use_with kerberos)
$(use_with xml libxml)
$(use_enable unicode mbstring)