summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-25 04:25:27 +0000
committerSam James <sam@gentoo.org>2021-11-25 04:25:27 +0000
commitd429e4f81bf613d0989abcda888ff59c838caffb (patch)
tree03859a8f11a4e277b201b55c37b2764fc4ea00a6
parentnet-libs/nodejs: Stabilize 14.17.6 x86, #818127 (diff)
downloadgentoo-d429e4f81bf613d0989abcda888ff59c838caffb.tar.gz
gentoo-d429e4f81bf613d0989abcda888ff59c838caffb.tar.bz2
gentoo-d429e4f81bf613d0989abcda888ff59c838caffb.zip
sci-libs/indilib: skip long-suffering base64 test on ppc*, sparc
No point in holding back stabilisations for months until we finally get fed up and stable it anyway. We know this test fails, it's been reported upstream, and it's not a regression, so let's skip it so we have an accurate idea of what the baseline is on these arches. Bug: https://bugs.gentoo.org/763126 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/indilib/indilib-1.9.3.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/sci-libs/indilib/indilib-1.9.3.ebuild b/sci-libs/indilib/indilib-1.9.3.ebuild
index 571c90b05d63..5291dd21585f 100644
--- a/sci-libs/indilib/indilib-1.9.3.ebuild
+++ b/sci-libs/indilib/indilib-1.9.3.ebuild
@@ -53,5 +53,17 @@ src_configure() {
}
src_test() {
+ local myctestargs=()
+
+ if use ppc || use ppc64 || use sparc ; then
+ # Broken on big endian for quite some time.
+ # Reported upstream: file needs to be replaced w/ a normal library
+ # for b64.
+ # bug #763126
+ myctestargs+=(
+ -E "(test_base64)"
+ )
+ fi
+
BUILD_DIR="${BUILD_DIR}"/test cmake_src_test
}