summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-18 16:33:39 +0100
committerSam James <sam@gentoo.org>2024-05-18 16:35:11 +0100
commitd42bc7d1338bcd5a4722c70322715091bd8d5199 (patch)
treef300658e41414c4a2bfc23052cfdc3c55fcf020f
parentpackage.mask: Last rite dev-python/aesara (diff)
downloadgentoo-d42bc7d1338bcd5a4722c70322715091bd8d5199.tar.gz
gentoo-d42bc7d1338bcd5a4722c70322715091bd8d5199.tar.bz2
gentoo-d42bc7d1338bcd5a4722c70322715091bd8d5199.zip
sys-apps/gentoo-functions: add 1.3
Kerin Millar (18): Reorganise the order in which functions are declared Declare some of the v-prefixed functions dynamically Remove some superfluous boolean variable declarations Declare eerror(), einfo() and ewarn() dynamically Improve the comments Have esyslog() check that EINFO_LOG is true instead of non-empty Don't call is_int() from _esetdent() Make _eend() much faster in bash Tweak the comment style for yesno() More comment improvements Rename _has_monochrome_terminal() to _has_color_terminal() Add a die() function Document variables influencing runtime behaviour test-functions: Fix a spurious test failure test-functions: Use test rather than [ to placate shellcheck Add an eqawarn() function Add an edo() function Reposition the declaration of _has_dumb_terminal() Sam James (1): meson.build: prepare for gentoo-functions-1.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/gentoo-functions/Manifest1
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index a245649d0908..f5516b3891a7 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -2,3 +2,4 @@ DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69c
DIST gentoo-functions-1.0.tar.bz2 18066 BLAKE2B a843de65d5d8f93396713dd5c80377dad478482d5749736ec3a08e0d0cc40f1a2ce5c967282b8060452d73f6377590f06e5c2a12cdfc753e7f6a18754cde4997 SHA512 057a7159a613108710a40f2ca54403adf64ab9649732be49d3a72314e2ca3c65d7a9093168e26ec12814203e1fe14cc1fc5cf2cefa2f923ec8bb714972d20f55
DIST gentoo-functions-1.1.tar.bz2 14277 BLAKE2B 150b5481668b766a6d1c3d8fff331df66c352d03971adaf7cb0332aef32cd881bd49a64165dc5070f24033f6b0a3d91c07d2e762b4d915fb7f137b8269def76a SHA512 1345f5b87f70422ff9c8577e75743fdc9ae871be4605b7983b602918bd352a396cfd2bb9e34cb1586b951bbca7264967a5412b9c89646bdcb60646b501f946e8
DIST gentoo-functions-1.2.tar.bz2 14277 BLAKE2B 17ce3a81a2563b11083553a51240f75b8fe174c573d06d645b475efdd7e537300ba656e10c814f30609eae15ed91cd00d4978b8bc0433935e6058d1ca8b7ccd7 SHA512 924f515c088811ddb7e2e7fd4fc75304866e2a159caa6619b2eb62eaab504b3720951bae8496f4faf93e9feae1c8b20ec3b4cbbc9cee1adbbdca703d5f87ee97
+DIST gentoo-functions-1.3.tar.bz2 15733 BLAKE2B c5cf336e97fe8f85063c9dca1f34427af6bcf853ad83f99aa0668d94be297c24b4e357f069918dce7dbd82aad61b876722df5d0bc2f880c14a47f6562ff9f642 SHA512 da3d9b3d7b56d87f2a684450529149a1c82b1dc67da65bdd454516a38e4d9ddfbfa3add3ec9141c678c83794ca5960a9e4bde95ffd623d2ade8fe2e910b709de
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.3.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.3.ebuild
new file mode 100644
index 000000000000..8df3a1e88bad
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Specifically needs GNU find, as well.
+RDEPEND=">=sys-apps/findutils-4.9"
+
+src_configure() {
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}