summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-09 17:37:29 +0100
committerSam James <sam@gentoo.org>2023-05-09 18:46:20 +0100
commitd45ba3abc85a2b1120d9c4c1f948d063e6a4f0c8 (patch)
tree360f2302831c353b5b38867e882cd7e7876c65a3
parentdev-util/cunit: wire up tests (diff)
downloadgentoo-d45ba3abc85a2b1120d9c4c1f948d063e6a4f0c8.tar.gz
gentoo-d45ba3abc85a2b1120d9c4c1f948d063e6a4f0c8.tar.bz2
gentoo-d45ba3abc85a2b1120d9c4c1f948d063e6a4f0c8.zip
dev-libs/pkcs11-helper: wire up (restricted) tests
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.29.0-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0-r1.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0-r1.ebuild
index fa7ca082dda3..fa9b65fb42cf 100644
--- a/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0-r1.ebuild
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,9 @@ SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.bz2"
LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="doc gnutls nss"
+IUSE="doc gnutls nss test"
+# Fails trying to load /usr/lib/pkcs11/provider.so?
+RESTRICT="!test? ( test ) test"
RDEPEND=">=dev-libs/openssl-0.9.7:=
gnutls? ( >=net-libs/gnutls-1.4.4:= )
@@ -29,7 +31,8 @@ src_configure() {
--disable-crypto-engine-mbedtls \
$(use_enable doc) \
$(use_enable gnutls crypto-engine-gnutls) \
- $(use_enable nss crypto-engine-nss)
+ $(use_enable nss crypto-engine-nss) \
+ $(use_enable test tests)
}
src_install() {