summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-03-18 05:12:11 +0800
committerYixun Lan <dlan@gentoo.org>2023-03-18 05:13:19 +0800
commitd4840720dd19e04b3f366990a9e43f6e88a11ee1 (patch)
tree0cc7043b224e0b5f0390bfc0345465fb6a549acc
parentdev-vcs/stgit: ignore LDFLAGS respect warning for rust app (diff)
downloadgentoo-d4840720.tar.gz
gentoo-d4840720.tar.bz2
gentoo-d4840720.zip
dev-vcs/stgit: filter out LTO flags
Closes: https://bugs.gentoo.org/897692 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-vcs/stgit/stgit-2.1.0.ebuild6
-rw-r--r--dev-vcs/stgit/stgit-2.2.0.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-vcs/stgit/stgit-2.1.0.ebuild b/dev-vcs/stgit/stgit-2.1.0.ebuild
index 695bde8fecfd..20fc837b2e4e 100644
--- a/dev-vcs/stgit/stgit-2.1.0.ebuild
+++ b/dev-vcs/stgit/stgit-2.1.0.ebuild
@@ -123,7 +123,7 @@ CRATES="
xattr-0.2.3
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="Manage a stack of patches using GIT as a backend"
HOMEPAGE="https://stacked-git.github.io"
@@ -144,6 +144,10 @@ RDEPEND=""
# update with proper path to binaries this crate installs, omit leading /
QA_FLAGS_IGNORED="usr/bin/${PN}"
+src_configure() {
+ filter-lto #bug 897692
+}
+
src_compile() {
cargo_src_compile
emake completion
diff --git a/dev-vcs/stgit/stgit-2.2.0.ebuild b/dev-vcs/stgit/stgit-2.2.0.ebuild
index c1d5ca48fd91..5c031f871323 100644
--- a/dev-vcs/stgit/stgit-2.2.0.ebuild
+++ b/dev-vcs/stgit/stgit-2.2.0.ebuild
@@ -175,7 +175,7 @@ CRATES="
xattr-0.2.3
"
-inherit cargo
+inherit cargo flag-o-matic
DESCRIPTION="Manage a stack of patches using GIT as a backend"
HOMEPAGE="https://stacked-git.github.io"
@@ -196,6 +196,10 @@ RDEPEND=""
# update with proper path to binaries this crate installs, omit leading /
QA_FLAGS_IGNORED="usr/bin/${PN}"
+src_configure() {
+ filter-lto #bug 897692
+}
+
src_compile() {
cargo_src_compile
emake completion