summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 07:20:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 07:36:25 +0200
commitd48b273216edcae0f3248e07589072605d5f9624 (patch)
tree623c1d2c5ffe7c5075f3a90c8dac17711ae8c90c
parentdev-db/mysql-connector-c: Build fixes (diff)
downloadgentoo-d48b273216edcae0f3248e07589072605d5f9624.tar.gz
gentoo-d48b273216edcae0f3248e07589072605d5f9624.tar.bz2
gentoo-d48b273216edcae0f3248e07589072605d5f9624.zip
dev-python/beartype: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/beartype/Manifest1
-rw-r--r--dev-python/beartype/beartype-0.13.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 1ee0086d2d5a..4fcc87730cba 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1 +1,2 @@
DIST beartype-0.12.0.gh.tar.gz 874431 BLAKE2B 0ad2a6c852b32427f8f9c5a8915e580601b24551e956d458a64cda4127bffe91a94ff676e2284daed6671e2c94515a234fd74dcb3d8a78616665490d1a780910 SHA512 2724f080a0f423a8b79b080843db696ee607f2e27ef52d726928086b643ebb31abe4e3ae24cae12075e222a21291d301601606640ca281ff98272578d5bf752e
+DIST beartype-0.13.0.gh.tar.gz 923713 BLAKE2B 151480693dfd3e30b41b38ef7ad2138ec323992461e2528fb059ac206304113578843dd1053838e3b132df4fff9f1e03706f02aa3d2b136da96f228d51386dd6 SHA512 062776e8d13c75106e1474aeada727562743689ad0131d2e218b222a0befe072f21af59e28bf7e69e1477beefc6cc1dc8cda2a476cf620b68746a3d350d701f5
diff --git a/dev-python/beartype/beartype-0.13.0.ebuild b/dev-python/beartype/beartype-0.13.0.ebuild
new file mode 100644
index 000000000000..2617cf4b98f1
--- /dev/null
+++ b/dev-python/beartype/beartype-0.13.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+# as of 0.13.0, sdist is missing mypy.ini required by tests
+# https://github.com/beartype/beartype/pull/230
+SRC_URI="
+ https://github.com/beartype/beartype/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+)