summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 18:19:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 19:53:35 +0200
commitd4a49ec77f1bffc527b1d4c58e619a920b7c17e1 (patch)
treec6fac8b8b293fc0feda3cfb3bc1ceeea15a70a96
parentdev-python/jupyterlab_pygments: Port to py3.10 (diff)
downloadgentoo-d4a49ec7.tar.gz
gentoo-d4a49ec7.tar.bz2
gentoo-d4a49ec7.zip
dev-python/nest_asyncio: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
index 256fec2c5b5a..cde8a0405f28 100644
--- a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,4 +15,13 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~sparc x86"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # incorrect args in test itself
+ tests/nest_test.py::NestTest::test_two_run_until_completes_in_one_outer_loop
+ )
+ epytest ${deselect[@]/#/--deselect }
+}