summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-11-03 19:45:14 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-11-03 22:00:54 +0100
commitd4a53343a37670bb57d3bf9ba4c36c7a21634f46 (patch)
tree08f233a75e6cc28968d42e5edd09e1147914275f
parentapp-vim/gitlog: stable for amd64+x86. (diff)
downloadgentoo-d4a53343.tar.gz
gentoo-d4a53343.tar.bz2
gentoo-d4a53343.zip
dev-python/pexpect: version bump to 4.2.1, EAPI bump.
Removed the old 4.0.1 because it was marked unstable and pretty old. Removed the removal of broken test-cases. Removed ~amd64-fbsd as dependency ptyprocess also doesn't have it. Gentoo-Bug: https://bugs.gentoo.org/527006 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2731 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/pexpect/Manifest2
-rw-r--r--dev-python/pexpect/pexpect-4.2.1.ebuild (renamed from dev-python/pexpect/pexpect-4.0.1.ebuild)21
2 files changed, 8 insertions, 15 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index a8e98a95527b..8343d1489c20 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,2 +1,2 @@
DIST pexpect-3.3.tar.gz 132330 SHA256 dfea618d43e83cfff21504f18f98019ba520f330e4142e5185ef7c73527de5ba SHA512 66cc501f1c7bb8ba0be4cdc0db840629f51416dc54ae44dc770adb38f1a385116b0a8b9bc7f1cc1447f05ede36ef1b519f5c4e710e6cb736c923ecfc87497cfa WHIRLPOOL e708e722d4e2598958f8d724b84148608e9a53041077b1a1a2af84d5281e11f0c6c050ee88489eebc48bd5556c22e0fe9386680d34b1941ddf21539296629513
-DIST pexpect-4.0.1.tar.gz 143657 SHA256 232795ebcaaf2e120396dbbaa3a129eda51757eeaae1911558f4ef8ee414fc6c SHA512 c2476f977964379faa3ecef1bc4800f3a87bd6cdd9e2d52e4e4f33a4060a97bb54f0770dfb5804d5a863eaf6ddef6b11be1d24f1617cc4837015202868ca7e87 WHIRLPOOL 91bc9e259f547b34d6a8847f3154601487e5f4d0ce1d7698078eb653fc12209c4d708f902e00cfb483f3872ce42063d65d8900dcaf9c727421f5e8b3d730e076
+DIST pexpect-4.2.1.tar.gz 143980 SHA256 3d132465a75b57aa818341c6521392a06cc660feb3988d7f1074f39bd23c9a92 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261 WHIRLPOOL 35176b56bdee1d7066705925c54014c33e18679e40f9182f15a223190904a6fead235c0d676806cc55a3f0f64666f446182056a29b27217ccc8990ecd9b8184e
diff --git a/dev-python/pexpect/pexpect-4.0.1.ebuild b/dev-python/pexpect/pexpect-4.2.1.ebuild
index 2a6a1ea14f23..755fc5da650c 100644
--- a/dev-python/pexpect/pexpect-4.0.1.ebuild
+++ b/dev-python/pexpect/pexpect-4.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
@@ -19,7 +19,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc examples test"
RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
@@ -27,16 +27,6 @@ DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-python_prepare_all() {
- # tests failing
- # https://github.com/pexpect/pexpect/issues/282
- # https://github.com/pexpect/pexpect/issues/283
- # https://github.com/pexpect/pexpect/issues/284
- rm tests/test_maxcanon.py tests/test_async.py || die
- touch .coveragerc || die
- distutils-r1_python_prepare_all
-}
-
python_compile_all() {
use doc && emake -C doc html
}
@@ -47,6 +37,9 @@ python_test() {
python_install_all() {
use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
distutils-r1_python_install_all
}