summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-14 12:23:11 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-14 12:23:11 -0700
commitd4b281c4356752d16282d691382027a274910071 (patch)
tree5dc7a8eaff54b2d9f2b9f46869b338be3988c266
parentmedia-libs/libsamplerate: Add live ebuild (diff)
downloadgentoo-d4b281c4356752d16282d691382027a274910071.tar.gz
gentoo-d4b281c4356752d16282d691382027a274910071.tar.bz2
gentoo-d4b281c4356752d16282d691382027a274910071.zip
media-sound/sndfile-tools: Add live ebuild
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--media-sound/sndfile-tools/sndfile-tools-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/sndfile-tools/sndfile-tools-9999.ebuild b/media-sound/sndfile-tools/sndfile-tools-9999.ebuild
new file mode 100644
index 000000000000..b09d2f4021f4
--- /dev/null
+++ b/media-sound/sndfile-tools/sndfile-tools-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A small collection of programs that use libsndfile"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/erikd/sndfile-tools.git"
+else
+ SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="jack"
+
+RDEPEND="
+ media-libs/libsndfile:=
+ media-libs/libsamplerate:=
+ x11-libs/cairo:=
+ sci-libs/fftw:3.0=
+ jack? ( media-sound/jack-audio-connection-kit:= )"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable jack)
+}