summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-25 22:45:11 +0000
committerSam James <sam@gentoo.org>2020-09-25 22:53:55 +0000
commitd5218b4731468b417aafae866f2c30924c9a337f (patch)
tree73c9bc258d7b498587c0a1e006460a1403a57994
parentsys-fs/bcache-tools: drop unmaintained live ebuild (diff)
downloadgentoo-d5218b4731468b417aafae866f2c30924c9a337f.tar.gz
gentoo-d5218b4731468b417aafae866f2c30924c9a337f.tar.bz2
gentoo-d5218b4731468b417aafae866f2c30924c9a337f.zip
www-apache/mod_xsendfile: port EAPI 4->6
We can't go to 7 yet because of the apache-module and depend.apache eclasses. Bug: https://bugs.gentoo.org/724212 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r1.ebuild b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..f8147aa6a2ba
--- /dev/null
+++ b/www-apache/mod_xsendfile/mod_xsendfile-1.0_beta1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit apache-module
+
+MY_PV="1.0b1"
+DESCRIPTION="Apache module that processes X-SENDFILE headers registered by the output handler"
+HOMEPAGE="https://tn123.org/mod_xsendfile/"
+SRC_URI="https://tn123.org/mod_xsendfile/beta/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux"
+
+APACHE2_MOD_CONF="50_${PN}"
+APACHE2_MOD_DEFINE="XSENDFILE"
+DOCFILES="docs/Readme.html"
+
+need_apache2
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}