summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-28 14:13:29 -0500
committerSam James <sam@gentoo.org>2023-11-29 04:09:00 +0000
commitd5552bb02bcdaf88004f485ebb16e1263a5edfe2 (patch)
tree67c904dd4f229bde998d30a750e318c9de6f3252
parentapp-accessibility/brltty: fix building python bindings too many times (diff)
downloadgentoo-d5552bb02bcdaf88004f485ebb16e1263a5edfe2.tar.gz
gentoo-d5552bb02bcdaf88004f485ebb16e1263a5edfe2.tar.bz2
gentoo-d5552bb02bcdaf88004f485ebb16e1263a5edfe2.zip
app-accessibility/brltty: add missing build dependency on setuptools
This does not use distutils-r1, so we need to manually add this dependency in order for the upstream Makefile to go drive a non-pep517 build all by itself. Closes: https://bugs.gentoo.org/905695 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-accessibility/brltty/brltty-6.6-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-accessibility/brltty/brltty-6.6-r1.ebuild b/app-accessibility/brltty/brltty-6.6-r1.ebuild
index 0588c791af36..5a7e5893753d 100644
--- a/app-accessibility/brltty/brltty-6.6-r1.ebuild
+++ b/app-accessibility/brltty/brltty-6.6-r1.ebuild
@@ -42,7 +42,10 @@ DEPEND="
ncurses? ( sys-libs/ncurses:0= )
pcm? ( media-libs/alsa-lib )
policykit? ( sys-auth/polkit )
- python? ( ${PYTHON_DEPS} )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
speech? (
app-accessibility/espeak-ng
app-accessibility/flite