summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-05 22:40:03 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-05 22:40:17 +0100
commitd564decfa7cff7c90d90b4944417c91fd7c1b048 (patch)
treeef85e0f9d5fefb831505dec594a8f3194880d1f0
parentmeson.eclass: append /usr/share/pkgconfig to PKG_CONFIG_PATH (diff)
downloadgentoo-d564decf.tar.gz
gentoo-d564decf.tar.bz2
gentoo-d564decf.zip
sys-libs/libcxx: drop invalid gcc-version check, bug #705282
gcc-4.7 is very old version. The version check uses lexicographical compare. It should use version compare to be valid. Let's just drop the check. Closes: https://bugs.gentoo.org/705282 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-libs/libcxx/libcxx-10.0.0.9999.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-10.0.0.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.9999.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-8.0.1.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-9.0.1.ebuild6
5 files changed, 1 insertions, 31 deletions
diff --git a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
index 5a3729e82ad3..6e1bba971a9b 100644
--- a/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
@@ -56,12 +56,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {
diff --git a/sys-libs/libcxx/libcxx-10.0.0.ebuild b/sys-libs/libcxx/libcxx-10.0.0.ebuild
index 24c015cc1bc5..20a1d2faae62 100644
--- a/sys-libs/libcxx/libcxx-10.0.0.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.0.ebuild
@@ -56,12 +56,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {
diff --git a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
index 7e8f34b8c137..c8f3b48d30c5 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
@@ -57,12 +57,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {
diff --git a/sys-libs/libcxx/libcxx-8.0.1.ebuild b/sys-libs/libcxx/libcxx-8.0.1.ebuild
index d126d9a2b013..f1ddc2f89dd0 100644
--- a/sys-libs/libcxx/libcxx-8.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-8.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,12 +66,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {
diff --git a/sys-libs/libcxx/libcxx-9.0.1.ebuild b/sys-libs/libcxx/libcxx-9.0.1.ebuild
index e5a479380d9d..c144def9c792 100644
--- a/sys-libs/libcxx/libcxx-9.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-9.0.1.ebuild
@@ -58,12 +58,6 @@ pkg_setup() {
eerror "and try again."
die
fi
- if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
- eerror "${PN} needs to be built with gcc-4.7 or later (or other"
- eerror "conformant compilers). Please use gcc-config to switch to"
- eerror "gcc-4.7 or later version."
- die
- fi
}
test_compiler() {