summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-17 09:38:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-17 10:31:09 +0200
commitd57b6a77369d94520564b5d7831e444355b99c9e (patch)
treef6bf8c6b5024609de52dcc04e388453352444f98
parentdev-python/zeroconf: Bump to 0.36.4 (diff)
downloadgentoo-d57b6a77.tar.gz
gentoo-d57b6a77.tar.bz2
gentoo-d57b6a77.zip
dev-python/hypothesis: Bump to 6.21.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.21.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1d55e804a4ad..56cdcf1691d7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -9,3 +9,4 @@ DIST hypothesis-python-6.21.0.tar.gz 9162663 BLAKE2B a5a2fbb7b377e6cf769c3454ca8
DIST hypothesis-python-6.21.1.tar.gz 9162836 BLAKE2B af52db17d51801d03496036f14b9b1e79667de64b4d5df925bffe00f67e11fb652f0e027bf250d3f4286e113052b3413b75fcd6c8922702924ca0eb9c46849dd SHA512 4e9d994e1323ee90cd4555ae3f310bcf4661079b287e000a65fbda7771e02c265c387df3bbbd0425d54b342de4fb20632b6a35842bc7a66affbdda159048359b
DIST hypothesis-python-6.21.3.tar.gz 9165503 BLAKE2B ee57b10021d5a8fd4731563e41e2583c879efd602779f5dfaa21a549b34bece29ebdd8386bcb637039b1c679a634f61ff68128c7d1e427ef4ca5ff571197b401 SHA512 0446df21f467cbabc6918a68b8a678db458ac798adaaf57090a756ff3a9b749dee550e77e1f78292d4bfe6f24caac175b104b4f4f1607521776c497649ac9c66
DIST hypothesis-python-6.21.4.tar.gz 9165577 BLAKE2B f2bf805d1ff1d469b2f62aa7095183a6eef2fa6f0e1cbd611a7e62dd978456ae199f64479ac43a7d34ffa7f3ae6b35c4aa1691dc863e6cc509914a23aa767f89 SHA512 7fd8a4c6a35417ac14999cfa668b9976314e022bc432a20387ef82b97021b626fe8a25e43ae92e5ecfdba8ab9cee0f182621132287c82511d64231272365fd06
+DIST hypothesis-python-6.21.5.tar.gz 9166120 BLAKE2B 6f51bd99c3c2f38e540f7e9720aa49ec62c0b8308ba5424f50ea72ea97172481dc28fd086d09c34449bde2601a68984158392fe19ad724a3048cba549c88a9fb SHA512 5cfa5196feffd5652e3c771fa8e99b8ebe563539d9a9ee0e87c5d9c08d363af19a207f76dd88fee0ff501f4d748d9cd1af87d01ef7d178d295f886123c11cd1a
diff --git a/dev-python/hypothesis/hypothesis-6.21.5.ebuild b/dev-python/hypothesis/hypothesis-6.21.5.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.21.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}