summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-15 21:25:11 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-15 22:20:41 +0100
commitd57d3ba7ff3ae705a18fe546e4150c1f15e827db (patch)
tree841854e1bb5d556cb1e5cbcc6770253d87c0f64b
parentsci-mathematics/eprover: bump to 3.0.03 (diff)
downloadgentoo-d57d3ba7ff3ae705a18fe546e4150c1f15e827db.tar.gz
gentoo-d57d3ba7ff3ae705a18fe546e4150c1f15e827db.tar.bz2
gentoo-d57d3ba7ff3ae705a18fe546e4150c1f15e827db.zip
dev-lang/algol68g: bump to 3.4.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/algol68g/Manifest1
-rw-r--r--dev-lang/algol68g/algol68g-3.4.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/algol68g/Manifest b/dev-lang/algol68g/Manifest
index 6f433188add5..c2030b69d1a0 100644
--- a/dev-lang/algol68g/Manifest
+++ b/dev-lang/algol68g/Manifest
@@ -1 +1,2 @@
DIST algol68g-3.4.4.tar.gz 661980 BLAKE2B c596dbc7579415bd386f26f483857d6ffababdb43e9bb7bd8edc3171b447c3da2dc8baa25ad8fadcadd7dfdaa4650620b8449c5b0d9d2e056775726e7db53dc6 SHA512 d3d9b1aac61871475877c4dd1078bc856fd6f1726bd374e16d8ac9530aee00cdd7fb618c96afa98b28fd66dee343cc7bf92e201787d4598e41dbd794ec3d0a9a
+DIST algol68g-3.4.6.tar.gz 661358 BLAKE2B 1a825534833f2b4ff4025c3ca2d2f022c1c78cf8f8a365cc12e97af1cc4994228b705d6395e5c967d6a195cd2fc542212025133e6410d4876d43c36952dc60c0 SHA512 831585cb90c524014cc199256dbcf663868b37804071774e2eac5c64944e25513df4584421042d02140ee2695a918caec9b99c837d117e775d3721bf09065fb4
diff --git a/dev-lang/algol68g/algol68g-3.4.6.ebuild b/dev-lang/algol68g/algol68g-3.4.6.ebuild
new file mode 100644
index 000000000000..6689c5616025
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}