summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-06 11:36:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-06 12:27:31 +0200
commitd585da320a892adaa1e9722474a487fd37c279db (patch)
tree79c4862bb7c8f419da3ba37c8278234863504731
parentdev-libs/boost: Drop 1.78.0-r2 (diff)
downloadgentoo-d585da320a892adaa1e9722474a487fd37c279db.tar.gz
gentoo-d585da320a892adaa1e9722474a487fd37c279db.tar.bz2
gentoo-d585da320a892adaa1e9722474a487fd37c279db.zip
dev-util/boost-build: Drop 1.78.0-r1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/boost-build/Manifest1
-rw-r--r--dev-util/boost-build/boost-build-1.78.0-r1.ebuild74
-rw-r--r--dev-util/boost-build/files/boost-build-1.78.0-fix-python-bindings-build.patch20
3 files changed, 0 insertions, 95 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index dda317544a26..7e0c56594141 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -1,2 +1 @@
-DIST boost_1_78_0.tar.bz2 110675550 BLAKE2B ed7da98862ec1e0a28472544400e6f44ffadbc967eed969ce6cb62b1c4f0b7a4b98a395269eb374b57326eff9cdb1dd6e47df9d1a9730aff7c926cc44388fb2d SHA512 9c34a387a203b99aa773eb0c59f5abac7a99ba10e4623653e793c1d5b29b99b88e0e4e0d4e2e4ca5d497c42f2e46e23bab66417722433a457dc818d7670bcbbf
DIST boost_1_79_0.tar.bz2 113456811 BLAKE2B 61f47ca022e60745868e6bdd3b5c75603dd68d878e126dcbb73de5b40fc03c0eec8eede3ec304ece58050435ef2fc1ed7eb763773c20673f85e32bbf4d5f978a SHA512 70909e0561c213d10a1fdd692f9ae7b293d3cdc63e925bdc207da9e9bba6e86474341100e7ee5de6d94f9561196b1a3a1597055a7b7382babf8931131170a312
diff --git a/dev-util/boost-build/boost-build-1.78.0-r1.ebuild b/dev-util/boost-build/boost-build-1.78.0-r1.ebuild
deleted file mode 100644
index 334acbcf9d5c..000000000000
--- a/dev-util/boost-build/boost-build-1.78.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_PV="$(ver_rs 1- _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://www.boost.org/build/"
-SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
-S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
- "${FILESDIR}"/${PN}-1.78.0-darwin-gentoo-toolchain.patch
- "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
- "${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
- "${FILESDIR}"/${PN}-1.78.0-no-implicit-march-flags.patch
- "${FILESDIR}"/${P}-fix-python-bindings-build.patch
-)
-
-src_unpack() {
- tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
-}
-
-src_prepare() {
- default
-
- pushd .. >/dev/null || die
- eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
- popd >/dev/null || die
-}
-
-src_configure() {
- # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
- append-lfs-flags
-}
-
-src_compile() {
- cd engine || die
- ${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
-}
-
-src_test() {
- # Forget tests, bjam is a lost cause
- :
-}
-
-src_install() {
- dobin engine/{bjam,b2}
-
- insinto /usr/share/boost-build/src
- doins -r "${FILESDIR}/site-config.jam" \
- ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
- build kernel options tools util
-
- find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-util/boost-build/files/boost-build-1.78.0-fix-python-bindings-build.patch b/dev-util/boost-build/files/boost-build-1.78.0-fix-python-bindings-build.patch
deleted file mode 100644
index ddcdf0850031..000000000000
--- a/dev-util/boost-build/files/boost-build-1.78.0-fix-python-bindings-build.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://bugs.gentoo.org/829031
-https://github.com/bfgroup/b2/pull/113
-
-From: Dmitry Arkhipov <grisumbras@gmail.com>
-Date: Thu, 9 Dec 2021 08:11:57 +0300
-Subject: [PATCH] Don't skip install targets if there's <build>no in ureqs
-
---- a/tools/stage.jam
-+++ b/tools/stage.jam
-@@ -478,6 +478,10 @@ class install-target-class : basic-target
- return [ sequence.unique $(result2) ] ;
- }
-
-+ rule skip-from-usage-requirements ( )
-+ {
-+ }
-+
- # Returns true iff 'type' is subtype of some element of 'types-to-include'.
- #
- local rule include-type ( type : types-to-include * )