summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-03-26 10:45:28 +0200
committerArsen Arsenović <arsen@gentoo.org>2023-03-27 22:27:11 +0200
commitd59b0c3b126f02ccaa86233e5c28c50a230875b6 (patch)
tree80135026f5b8345617cfc44f28b055916a71a246
parenttoolchain-autoconf.eclass: Add option to disable Info slotting (diff)
downloadgentoo-d59b0c3b126f02ccaa86233e5c28c50a230875b6.tar.gz
gentoo-d59b0c3b126f02ccaa86233e5c28c50a230875b6.tar.bz2
gentoo-d59b0c3b126f02ccaa86233e5c28c50a230875b6.zip
sys-devel/autoconf: Set TC_AUTOCONF_BREAK_INFOS=yes to prevent changes
Recently, the toolchain-autoconf class was edited not to naively slot Info pages, breaking them in the process. To prevent existing revisions from changing contents, TC_AUTOCONF_BREAK_INFOS was added to permit using old behavior currently. Closes: https://bugs.gentoo.org/902461 Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
-rw-r--r--sys-devel/autoconf/autoconf-2.13-r2.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.13-r7.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r5.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.69-r8.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.71-r1.ebuild4
-rw-r--r--sys-devel/autoconf/autoconf-2.71-r5.ebuild4
6 files changed, 18 insertions, 6 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13-r2.ebuild b/sys-devel/autoconf/autoconf-2.13-r2.ebuild
index f26c02ae862c..787687f1b8c0 100644
--- a/sys-devel/autoconf/autoconf-2.13-r2.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.13-perl-5.26.patch
)
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_configure() {
# make sure configure is newer than configure.in
touch configure || die
diff --git a/sys-devel/autoconf/autoconf-2.13-r7.ebuild b/sys-devel/autoconf/autoconf-2.13-r7.ebuild
index 055d8286769d..b4942c1bcb7b 100644
--- a/sys-devel/autoconf/autoconf-2.13-r7.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,8 @@ PATCHES=(
"${FILESDIR}"/${P}-Clang-16-fixes-for-various-tests.patch
)
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_configure() {
# make sure configure is newer than configure.in
touch configure || die
diff --git a/sys-devel/autoconf/autoconf-2.69-r5.ebuild b/sys-devel/autoconf/autoconf-2.69-r5.ebuild
index f51aa71c2d0a..947bf12f49b4 100644
--- a/sys-devel/autoconf/autoconf-2.69-r5.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,8 @@ PATCHES=(
"${WORKDIR}"/patches/${P}-runstatedir_info.patch
)
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
diff --git a/sys-devel/autoconf/autoconf-2.69-r8.ebuild b/sys-devel/autoconf/autoconf-2.69-r8.ebuild
index 3730430ac8a4..1c1ebcfc681e 100644
--- a/sys-devel/autoconf/autoconf-2.69-r8.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -46,6 +46,8 @@ PATCHES=(
"${WORKDIR}"/patches/${P}-texinfo.patch
)
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
diff --git a/sys-devel/autoconf/autoconf-2.71-r1.ebuild b/sys-devel/autoconf/autoconf-2.71-r1.ebuild
index 7ef4e0bcbeb7..9f2ea4b973fe 100644
--- a/sys-devel/autoconf/autoconf-2.71-r1.ebuild
+++ b/sys-devel/autoconf/autoconf-2.71-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -43,6 +43,8 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
PATCHES=( "${FILESDIR}/${P}-time.patch" )
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then
diff --git a/sys-devel/autoconf/autoconf-2.71-r5.ebuild b/sys-devel/autoconf/autoconf-2.71-r5.ebuild
index 7749d47f435e..722aa8cc1e22 100644
--- a/sys-devel/autoconf/autoconf-2.71-r5.ebuild
+++ b/sys-devel/autoconf/autoconf-2.71-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -50,6 +50,8 @@ PATCHES=(
"${FILESDIR}"/${P}-K-R-decls-clang-deux.patch
)
+TC_AUTOCONF_BREAK_INFOS=yes
+
src_prepare() {
# usr/bin/libtool is provided by binutils-apple, need gnu libtool
if [[ ${CHOST} == *-darwin* ]] ; then