summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-07 06:24:29 +0000
committerSam James <sam@gentoo.org>2021-06-07 07:13:53 +0000
commitd5aff08dc0ecd4e5d6c1f426e6133197b9964d93 (patch)
tree7d0584b08e7705606579bf856ff0a33a1351bc18
parentdev-python/ipython: Remove old (diff)
downloadgentoo-d5aff08dc0ecd4e5d6c1f426e6133197b9964d93.tar.gz
gentoo-d5aff08dc0ecd4e5d6c1f426e6133197b9964d93.tar.bz2
gentoo-d5aff08dc0ecd4e5d6c1f426e6133197b9964d93.zip
x11-misc/evolvotron: fix build with GCC 11
Closes: https://bugs.gentoo.org/787101 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild26
-rw-r--r--x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch21
2 files changed, 34 insertions, 13 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
index 2cfacb68a556..52497e1e2485 100644
--- a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit qmake-utils
DESCRIPTION="Generative art image evolver"
-HOMEPAGE="
- https://sourceforge.net/projects/evolvotron/
-"
+HOMEPAGE="https://sourceforge.net/projects/evolvotron/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
@@ -23,13 +23,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-DOCS=(
- BUGS NEWS README TODO USAGE
-)
-HTML_DOCS=(
- evolvotron.html
+DOCS=( BUGS NEWS README TODO USAGE )
+HTML_DOCS=( evolvotron.html )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-gcc11-predicate-decl.patch
)
-S=${WORKDIR}/${PN}
src_configure() {
eqmake5 main.pro
@@ -37,9 +36,9 @@ src_configure() {
src_compile() {
local etsubdir
- for etsubdir in \
- libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
- do
+ local targets=( libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate )
+
+ for etsubdir in ${targets[@]}; do
emake sub-${etsubdir}
done
}
@@ -49,6 +48,7 @@ src_install() {
for bin in ${PN}{,_mutate,_render}; do
dobin ${bin}/${bin}
done
+
doman man/man1/*
einstalldocs
}
diff --git a/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch b/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch
new file mode 100644
index 000000000000..e21de137f746
--- /dev/null
+++ b/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/787101
+--- a/libevolvotron/mutatable_image_computer_farm.h
++++ b/libevolvotron/mutatable_image_computer_farm.h
+@@ -45,7 +45,7 @@ class MutatableImageComputerFarm
+ {
+ public:
+ //! Compare task priorities.
+- bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1)
++ bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1) const
+ {
+ return (t0->priority() < t1->priority());
+ }
+@@ -56,7 +56,7 @@ class MutatableImageComputerFarm
+ {
+ public:
+ //! Compare task priorities.
+- bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1)
++ bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1) const
+ {
+ return (t0->priority() > t1->priority());
+ }