summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-28 21:37:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-28 23:02:17 -0400
commitd5bab85e064169bc48b49c455444f8f5e9dfaef3 (patch)
treef2117ad4229a1e417c4f2a92059605af74b513c3
parentmedia-libs/glfw: rename wayland useflag to wayland-only (diff)
downloadgentoo-d5bab85e.tar.gz
gentoo-d5bab85e.tar.bz2
gentoo-d5bab85e.zip
media-libs/glfw: tidy ebuild
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-libs/glfw/glfw-3.3.4-r1.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/media-libs/glfw/glfw-3.3.4-r1.ebuild b/media-libs/glfw/glfw-3.3.4-r1.ebuild
index 1cf0a04e0032..d813e2d1124d 100644
--- a/media-libs/glfw/glfw-3.3.4-r1.ebuild
+++ b/media-libs/glfw/glfw-3.3.4-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
CMAKE_ECLASS=cmake
inherit cmake-multilib
-DESCRIPTION="The Portable OpenGL FrameWork"
+DESCRIPTION="Portable OpenGL FrameWork"
HOMEPAGE="https://www.glfw.org/"
SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -15,8 +15,13 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
IUSE="wayland-only"
+# note: libglfw uses dlopen() for most of these at runtime
RDEPEND="
x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ wayland-only? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/mesa[egl,wayland,${MULTILIB_USEDEP}]
+ )
!wayland-only? (
virtual/opengl[${MULTILIB_USEDEP}]
x11-libs/libX11[${MULTILIB_USEDEP}]
@@ -24,32 +29,24 @@ RDEPEND="
x11-libs/libXinerama[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
- )
- wayland-only? (
- dev-libs/wayland[${MULTILIB_USEDEP}]
- media-libs/mesa[egl,wayland,${MULTILIB_USEDEP}]
- )
-"
+ )"
DEPEND="
${RDEPEND}
+ wayland-only? ( dev-libs/wayland-protocols )
!wayland-only? (
x11-base/xorg-proto
x11-libs/libXi[${MULTILIB_USEDEP}]
- )
- wayland-only? ( dev-libs/wayland-protocols )
-"
+ )"
BDEPEND="
wayland-only? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
- )
-"
+ )"
src_configure() {
local mycmakeargs=(
-DGLFW_BUILD_EXAMPLES=no
- -DGLFW_USE_WAYLAND="$(usex wayland-only wayland)"
- -DBUILD_SHARED_LIBS=1
+ -DGLFW_USE_WAYLAND=$(usex wayland-only)
)
cmake-multilib_src_configure
}