summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-02-26 16:57:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-03-07 10:27:43 +0200
commitd5c719062be0760f078db32c62c8dd7560c8a5ed (patch)
treecfa1a0ef4d7b678d70f58f02bea206ab5c554ddf
parentwww-apps/hugo: remove -race, use EGO_BUILD_FLAGS (diff)
downloadgentoo-d5c719062be0760f078db32c62c8dd7560c8a5ed.tar.gz
gentoo-d5c719062be0760f078db32c62c8dd7560c8a5ed.tar.bz2
gentoo-d5c719062be0760f078db32c62c8dd7560c8a5ed.zip
www-apps/hugo: drop 0.108.0, 0.110.0
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/29811 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.108.0.ebuild93
-rw-r--r--www-apps/hugo/hugo-0.110.0.ebuild96
3 files changed, 0 insertions, 191 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index 744804a5a9f4..549c73109538 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -1,4 +1,2 @@
-DIST hugo-0.108.0-vendor.tar.xz 5759708 BLAKE2B 6b3f93b0f29cb57afcb5a2e05ec2dc5ba276cb5d30cd2c3996fbed20fa2a9e8f464e580dd42302819d18b5cc35b2f2ab16e9e11faa175fc1c56591da56c2be31 SHA512 b4baaa6acc227e8d169362c9adcf60c2365413231beedb3ff21d7d7103e2a3d3bb19d30950e68978841de2923b3cc2171474ea3811f0dbcc1e0f173c453a8441
-DIST hugo-0.108.0.tar.gz 29048088 BLAKE2B dd9654985fe0221ddb6b5f74c4d7f3259e587ee71522d6304d102849e63d2abd926987699fd7bac35c1a3bd5c6a195b4308249039d1a86cadae6dad641b75085 SHA512 450030bd657468bcf62de9d60def0c4f977ed4ba4b8ff830eae146622f678fedf656e3637bbdb44ac4289f857f5a1259ea0cfa66a45a14ea92860eee86dbf9fa
DIST hugo-0.110.0-vendor.tar.xz 5792924 BLAKE2B a70283d9b5764c3340591e40d6472c0f14b029e5bed086c4f294951e00a45041a869868884328ea39b75caccf8e2089250a98502a3ec38c730989a77e55c976b SHA512 c6a0cd262934b6434eac7122a0ec257ca4eec1611b938585e6ee22d56991632fd5e52c061d552772e0e8bd10e13c23aecc461d52c23dff009e8e522b651642da
DIST hugo-0.110.0.tar.gz 29055652 BLAKE2B d8c9e04c3141f02eeea1a951ba92c552148b604817e60041a3b944ccea37565ab8a6c3a47300877f5497d4575df4cdf598627d8dea65a1c935073b7bd8e99b70 SHA512 b64a6fa50201c0d95bf49fd0193138123163e0dad077491cc4c3e0d851de03ed2cd2e81482c1e6291d9a10d2d99f89c9dbbcfaafcd17f702906901dc6f28b3de
diff --git a/www-apps/hugo/hugo-0.108.0.ebuild b/www-apps/hugo/hugo-0.108.0.ebuild
deleted file mode 100644
index 8985198b2e7d..000000000000
--- a/www-apps/hugo/hugo-0.108.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Fast static HTML and CSS website generator"
-HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
-SRC_URI="
- https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
-"
-
-# NOTE: To create the vendor tarball, run:
-# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~x86"
-IUSE="doc +sass test"
-
-BDEPEND="
- >=dev-lang/go-1.18
- test? (
- dev-python/docutils
- dev-ruby/asciidoctor
- virtual/pandoc
- )
-"
-RDEPEND="
- >=media-libs/libwebp-1.2.3-r1:=
- sass? ( dev-libs/libsass:= )
-"
-DEPEND="${RDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
- "${FILESDIR}"/${PN}-0.104.3-skip-some-tests.patch
- "${FILESDIR}"/${PN}-0.99.1-test-timeout.patch
-)
-
-src_configure() {
- export CGO_ENABLED=1
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
-
- MY_BUILDFLAGS="$(usev sass "-tags extended")"
-
- default
-}
-
-src_compile() {
- mkdir -pv bin || die
- ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
-
- bin/hugo gen man --dir man || die
-
- mkdir -pv completions || die
- bin/hugo completion bash > completions/hugo || die
- bin/hugo completion fish > completions/hugo.fish || die
- bin/hugo completion zsh > completions/_hugo || die
-
- if use doc ; then
- bin/hugo gen doc --dir doc || die
- fi
-}
-
-src_test() {
- ego test -race "./..." ${MY_BUILDFLAGS}
-}
-
-src_install() {
- dobin bin/*
- doman man/*
-
- dobashcomp completions/${PN}
-
- insinto /usr/share/fish/vendor_completions.d
- doins completions/${PN}.fish
-
- insinto /usr/share/zsh/site-functions
- doins completions/_${PN}
-
- if use doc ; then
- dodoc -r doc/*
- fi
-}
diff --git a/www-apps/hugo/hugo-0.110.0.ebuild b/www-apps/hugo/hugo-0.110.0.ebuild
deleted file mode 100644
index 910c8a28804b..000000000000
--- a/www-apps/hugo/hugo-0.110.0.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Fast static HTML and CSS website generator"
-HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
-SRC_URI="
- https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
-"
-
-# NOTE: To create the vendor tarball, run:
-# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT Unlicense"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
-IUSE="doc +sass test"
-
-BDEPEND="
- >=dev-lang/go-1.18
- test? (
- dev-python/docutils
- dev-ruby/asciidoctor
- virtual/pandoc
- )
-"
-RDEPEND="
- >=media-libs/libwebp-1.2.3-r1:=
- sass? ( dev-libs/libsass:= )
-"
-DEPEND="${RDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
- "${FILESDIR}"/${PN}-0.110.0-skip-some-tests.patch
- "${FILESDIR}"/${PN}-0.99.1-test-timeout.patch
-)
-
-src_configure() {
- export CGO_ENABLED=1
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
-
- MY_BUILDFLAGS="$(usev sass "-tags extended")"
-
- default
-}
-
-src_compile() {
- mkdir -pv bin || die
- ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- ${MY_BUILDFLAGS} -o "${S}/bin/hugo"
-
- bin/hugo gen man --dir man || die
-
- mkdir -pv completions || die
- bin/hugo completion bash > completions/hugo || die
- bin/hugo completion fish > completions/hugo.fish || die
- bin/hugo completion zsh > completions/_hugo || die
-
- if use doc ; then
- bin/hugo gen doc --dir doc || die
- fi
-}
-
-src_test() {
- # workaround for mysteriously added -buildmode=pie
- # <https://github.com/gentoo/gentoo/pull/29069#discussion_r1085026796>
- MY_BUILDFLAGS="-buildmode=exe ${MY_BUILDFLAGS}"
- ego test -race "./..." ${MY_BUILDFLAGS}
-}
-
-src_install() {
- dobin bin/*
- doman man/*
-
- dobashcomp completions/${PN}
-
- insinto /usr/share/fish/vendor_completions.d
- doins completions/${PN}.fish
-
- insinto /usr/share/zsh/site-functions
- doins completions/_${PN}
-
- if use doc ; then
- dodoc -r doc/*
- fi
-}