summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-09-27 19:51:45 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-09-27 19:51:54 +0200
commitd5d7ad6c39f24945b566cba590ba13e329ef9147 (patch)
tree256a77e58219c5478b7ebcf13f037c75497a7ce3
parentprofiles: x86: mask USE=qtav for media-video/orion (diff)
downloadgentoo-d5d7ad6c.tar.gz
gentoo-d5d7ad6c.tar.bz2
gentoo-d5d7ad6c.zip
media-video/orion: 1.6.5 bump
Also add qtav option, now that it is in portage Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--media-video/orion/Manifest1
-rw-r--r--media-video/orion/metadata.xml4
-rw-r--r--media-video/orion/orion-1.6.5.ebuild45
3 files changed, 49 insertions, 1 deletions
diff --git a/media-video/orion/Manifest b/media-video/orion/Manifest
index 6168b4a52a55..bd0019233aec 100644
--- a/media-video/orion/Manifest
+++ b/media-video/orion/Manifest
@@ -1 +1,2 @@
DIST orion-1.6.1.tar.gz 614216 BLAKE2B 8fc0909c1dd433e72d4ed41046d38a861ec48cbe6e93e1a9cc48f31cb3ef381e1b5b998c501d20756883431464eef798859b9ba4d086b89575281dbc17afca69 SHA512 3db0b59a89d2364f2d0586c3f318fc793f73a17d767adb0f44b89830e397be6f24c2ab662b7c84e7d857bc42b952fdf7fa280090313f5e39e37205eb8fb6dc9e
+DIST orion-1.6.5.tar.gz 624005 BLAKE2B ca2c40a299ab3f1abc7f383f2a5f39ebbe1e6ce6737efc3da0acd8cbbc04753dab865f417bd8e39d7e42dd7db8de703dd3b251296b8820a9027ca3ad2cd5de1d SHA512 6add27b81bf2520354e1a8854c2be4caf81d1c7c161003cb86bb4911852965cff938381c0ea481c64dc91c36d45f5af44cfb6e9a6d1c379f8b3b3011bbe47c6f
diff --git a/media-video/orion/metadata.xml b/media-video/orion/metadata.xml
index 98d88483f290..9c91e6887c8b 100644
--- a/media-video/orion/metadata.xml
+++ b/media-video/orion/metadata.xml
@@ -6,7 +6,9 @@
<name>Bernard Cafarelli</name>
</maintainer>
<use>
- <flag name="mpv">Use the <pkg>media-video/mpv</pkg> player (upstream default) instead of the <pkg>dev-qt/qtmultimedia</pkg> one</flag>
+ <flag name="mpv">Use the <pkg>media-video/mpv</pkg> player (upstream default)</flag>
+ <flag name="qtav">Use the <pkg>media-libs/qtav</pkg> player</flag>
+ <flag name="qtmedia">Use the <pkg>dev-qt/qtmultimedia</pkg></flag>
</use>
<upstream>
<remote-id type="github">alamminsalo/orion</remote-id>
diff --git a/media-video/orion/orion-1.6.5.ebuild b/media-video/orion/orion-1.6.5.ebuild
new file mode 100644
index 000000000000..17c83ddd2d0d
--- /dev/null
+++ b/media-video/orion/orion-1.6.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils qmake-utils
+
+DESCRIPTION="Cross-platform Twitch client"
+HOMEPAGE="https://alamminsalo.github.io/orion/"
+SRC_URI="https://github.com/alamminsalo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mpv qtav qtmedia"
+
+DEPEND=">=dev-qt/qtquickcontrols2-5.8:5
+ >=dev-qt/qtsvg-5.8:5
+ >=dev-qt/qtwebengine-5.8:5
+ mpv? ( media-video/mpv[libmpv] )
+ qtav? ( media-libs/qtav )
+ qtmedia? ( >=dev-qt/qtmultimedia-5.8:5 )"
+RDEPEND="${DEPEND}
+ !mpv? ( media-plugins/gst-plugins-hls )"
+
+REQUIRED_USE="^^ ( mpv qtav qtmedia )"
+
+src_configure() {
+ local PLAYER
+ if use mpv; then
+ PLAYER=mpv
+ elif use qtav; then
+ PLAYER=qtav
+ else
+ PLAYER=multimedia
+ fi
+ eqmake5 ${PN}.pro CONFIG+=${PLAYER}
+}
+
+src_install() {
+ dobin ${PN}
+ domenu distfiles/*.desktop
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins distfiles/${PN}.svg
+}