summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-09-11 13:43:30 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-09-11 13:44:13 -0500
commitd5e5778f271ae34850281b9011729d7c9a015e6c (patch)
tree073a1337a4eeeec9f95c5470db3c273b32599d10
parentwww-client/opera: Remove USE=kde (bug #630662). (diff)
downloadgentoo-d5e5778f.tar.gz
gentoo-d5e5778f.tar.bz2
gentoo-d5e5778f.zip
app-emulation/go-secbench: new package
This tool runs and parses the output of the docker-bench-security tool to make it more readable. Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-emulation/go-secbench/Manifest1
-rw-r--r--app-emulation/go-secbench/go-secbench-0.1.0.ebuild26
-rw-r--r--app-emulation/go-secbench/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/go-secbench/Manifest b/app-emulation/go-secbench/Manifest
new file mode 100644
index 000000000000..0eb3e7816489
--- /dev/null
+++ b/app-emulation/go-secbench/Manifest
@@ -0,0 +1 @@
+DIST go-secbench-0.1.0.tar.gz 1281488 SHA256 6c0142c38722294d9b53436c8f0afd302ed0bd244db83490c607b2648d1902d8 SHA512 4712ef56385993ed1e660c1843a1d7e9cd807a3ca8bf935767e8d2965aef25c5b3a7a88d4ed7c072fe124a6b05900bd444cdbc0cee879e80844fb5f695732f2b WHIRLPOOL b12b392966580aea3f52145a3fc310369726ababeccf33f6c903554f2e0d67f2b8286a86da5583ea20d348f3d8040b9db12c1a19ac0f771c6746ade9ed562f19
diff --git a/app-emulation/go-secbench/go-secbench-0.1.0.ebuild b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
new file mode 100644
index 000000000000..fdceccf32659
--- /dev/null
+++ b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/qnib/go-secbench"
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="run and evaluate the docker security benchmark"
+HOMEPAGE="https://github.com/qnib/go-secbench"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND="dev-lang/go"
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
+}
+
+src_install() {
+ dobin bin/${PN}
+dodoc "src/${EGO_PN}/README.md"
+}
diff --git a/app-emulation/go-secbench/metadata.xml b/app-emulation/go-secbench/metadata.xml
new file mode 100644
index 000000000000..3414fcec300a
--- /dev/null
+++ b/app-emulation/go-secbench/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This tool runs and evaluates the docker security benchmark.
+ </longdescription>
+</pkgmetadata>