summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 14:30:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 16:50:39 -0500
commitd602da49d4ba66022ac5838556d0dbc82ea78dee (patch)
treeaca3429bf82380da79bfb4eb5bedea5a34dc5ee6
parentdev-python/tooz: 1.58.0 bup (diff)
downloadgentoo-d602da49.tar.gz
gentoo-d602da49.tar.bz2
gentoo-d602da49.zip
dev-python/os-win: 2.2.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/os-win/Manifest1
-rw-r--r--dev-python/os-win/os-win-2.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
index ab62376500db..f53c9df63660 100644
--- a/dev-python/os-win/Manifest
+++ b/dev-python/os-win/Manifest
@@ -1,3 +1,4 @@
DIST os-win-0.4.0.tar.gz 134421 SHA256 369d9483340ab48a5c145e4863082d2c611a02a467b7609227e3432a26880283 SHA512 6ffc33c8dbeb834ee588a8b84fb3fc6d7f6bf886d22307cac46c6f769c0d645bc76fd432be0cd8d3b76d0119ef6f5fe3276482cfda7880462f7af6969748a53e WHIRLPOOL 6c3c643b3992f98eb8551d19d067e8a56809a10005abf0940c270a77c4f1066469b367045c6e1be9f453b87db67f4f7fe9d3f614589887bc0e5d1d46c62b2099
DIST os-win-1.2.1.tar.gz 157535 SHA256 be9749c8bd49d9a65895b8324374e3beafd6e3b0987840e87a888f03e194a7a7 SHA512 2893dda81267fa451afe3e0570b30fc835587237ec20ebc67d0fb454bcf2d0bcf8cfe215e6103f2a165f68c9ccabefd7ff0dbd08b2d52da49f96b2b8fc84cb50 WHIRLPOOL 7189aa28f04cce6d5119030be2fbd875c77d2e2af4f5b93244fbda4817d3090bb78d4d58dbf90b2e26af1ea72220faa14fbe2f8db025e83305d758c34df932cf
DIST os-win-1.4.1.tar.gz 170022 SHA256 88c95da00bab00672d128943400d9c3fd6ca2c4f17b0d20eaaf242ebf6b0866b SHA512 1bc21be5e336a90c3bc96ee3e727e3192fdc8baab548ba67c5b68d10b88661759d02c006a3f579bc0c66ab0c4d63a4b40f684e4f7c6cab9431256cb2fbc1634c WHIRLPOOL b6458e0e2a4a38b1e9d6972397b6ddcc582bbf1c0cac737282c6ce7c4bd91322d3a326d1203d6d4fb6dd345f41f90ea4ff57252ecf89a2cf0f6544f87f38cfa7
+DIST os-win-2.2.0.tar.gz 192662 SHA256 4f668ce616289ba0a535c14445186b8ae7fd5cbdeb3921ccb50fd4729ca1191f SHA512 02bb9b7ddaa7b3807ce66ce32242fe9938f28bde6880cf9ed461072e764e41a34a1238ccdc8b67ebc95a07ac003bb0771b8943602582ede6c8a41440f865060b WHIRLPOOL 4e14808719305da9d0097d5156e48a40ff180a29038a1605415a03a494c7402c91f65f961b3225fb34c81d275438092619d05af2c08e955a61e98990f2b33367
diff --git a/dev-python/os-win/os-win-2.2.0.ebuild b/dev-python/os-win/os-win-2.2.0.ebuild
new file mode 100644
index 000000000000..23d802daa6b6
--- /dev/null
+++ b/dev-python/os-win/os-win-2.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}