summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-23 15:30:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-23 15:30:35 +0100
commitd609e84af4bec0968f328bcb8ce043b8af7119df (patch)
treef6bf53e56a0a3cf183802393356d3d8edf926d26
parentdev-python/mkdocs-material: Bump to 9.4.11 (diff)
downloadgentoo-d609e84a.tar.gz
gentoo-d609e84a.tar.bz2
gentoo-d609e84a.zip
dev-python/fonttools: Bump to 4.45.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.45.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 36b556deeec7..943fd2b13cc3 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -3,3 +3,4 @@ DIST fonttools-4.44.0.gh.tar.gz 3771969 BLAKE2B 26a9bef8e6f5595bca8a27ca1b46cfa1
DIST fonttools-4.44.1.gh.tar.gz 3772404 BLAKE2B 75ea507c234846e26d3e1693c3ae8c23ac45c1ed0496958cf9589928e2918b496038f8729c7418080adf64e94a1ae0cb156e2b5925b69885660225daa8596359 SHA512 574dc1661c5b6cd63d70f4195f06e2dc6fe75bf84912720390314c2b3ed5edaaf05cc8879520b356857aef4cfd23ef2ae4c42c5cf5048359be63f757644d95b2
DIST fonttools-4.44.3.gh.tar.gz 3775926 BLAKE2B fcc482ffa6163f895cf6ea8721dae3ce85beea3bbf3d19c30e5f2a681356e66ff5ffc3ee4b228244eaebbcc76e397ec1e841ed3f96fda2eb2561e26f0b90a174 SHA512 cedac35c1273d95785095678a90aef58307b5c66bcd3c2e4f72f6642412265e783afc5e0e1e4cff77ceb31f1f5406ae24d130856c41821998da94e088628823e
DIST fonttools-4.45.0.gh.tar.gz 3785706 BLAKE2B d5e9d4ec5b04e789379834846b4545a3aac7c793127aff017a09fd07439413890919241a3692416b7f570ccb8b41e86d46a7f3a132d86357b1c8f63a1cbc1b9f SHA512 6132912f547e5b74f06749bf098cd31e27b1ff4ecfee874a29a1b82d339575b94e5f1580ee4d5b8b7588ae7382f298fd5ef537b165477a2f37e9112d51c58c2d
+DIST fonttools-4.45.1.gh.tar.gz 3787665 BLAKE2B 5f7f821eda2fe3e9f9e72417e9e545d495322fa363a1b4760f46ade75c803ec8a66ed2c7e1ab7c7eb84ff7b375d038b8ac02f56201ed2b73844e83ed1dcf25d3 SHA512 58926a3e8cb27148753010c66b5eee071ea88cd8a568fe10e76c94de190fa0685acbb6be1393b03f8fddfe6142b0d523bb17573f4db25c0e057a26f9579c5219
diff --git a/dev-python/fonttools/fonttools-4.45.1.ebuild b/dev-python/fonttools/fonttools-4.45.1.ebuild
new file mode 100644
index 000000000000..3d1e57011c88
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.45.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}