summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:03:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-19 21:24:54 +0200
commitd60fe61eb11e9d4c8dc840d197c4957ed8bc11ed (patch)
tree300cf8f5c768e7e251149674e3b5a3283224cc93
parentkde-frameworks/ktextwidgets: 5.116.0 version bump (diff)
downloadgentoo-d60fe61eb11e9d4c8dc840d197c4957ed8bc11ed.tar.gz
gentoo-d60fe61eb11e9d4c8dc840d197c4957ed8bc11ed.tar.bz2
gentoo-d60fe61eb11e9d4c8dc840d197c4957ed8bc11ed.zip
kde-frameworks/kwallet: 5.116.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/kwallet-5.116.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index b98911815e00..7efa2f19158d 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-5.115.0.tar.xz 353124 BLAKE2B 18f9d51c52e60e20d44c3bbbb385cdd4d2b696d1a2b3a36700f44577d04d3ea652f848a6c680db4626d9516ff0848181a098efcaa0b6e4bbf282f9831c576096 SHA512 8870af27ab6dfe5a7f9c60a8199b917e3f0ad81e48524c5ea383c39d6e3ca6a2fbe7bbce9b645a190c33a58bc7e63347e1737b6f55783fefa2a46bf7bab598fe
+DIST kwallet-5.116.0.tar.xz 353948 BLAKE2B d8c38a71e72ea9ce316a9f5af440c502b4e21b69f9ae40e740a209bde3aaa6519dd26079c99ffe1b7441a464c1ebdb34b550f9127be89c0f2baede68003eb462 SHA512 fc96b2e87e565dadb960159c5412cc0862454331824510405f434dfda2146ecf4e2ca133345c0c46608143da10265f154a0225f4d8d82ae6f11a184b222d663d
DIST kwallet-6.2.0.tar.xz 352000 BLAKE2B a635e97a68327b222195d7d1fb6a0b36745a0f2eca866a98a1183c6391cd2c3c480261f13f83e8438c048674b0a23bf86ce1c99f6482d2a943b6cc6e710d2e45 SHA512 6a884727ceaa935cb6bc8eea550fd38828801526291b95dc5bac8ea8a03187edefe7667b1e0345f0a48eeadcb96850be4aaec796d04d0a79883d35d89200cf6c
diff --git a/kde-frameworks/kwallet/kwallet-5.116.0.ebuild b/kde-frameworks/kwallet/kwallet-5.116.0.ebuild
new file mode 100644
index 000000000000..422b94f04d8d
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-5.116.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gpg kf6compat +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt5(+)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ !kf6compat? ( gpg? ( >=app-crypt/gpgme-1.7.1:=[cxx,qt5] ) )
+"
+RDEPEND="${DEPEND}
+ kf6compat? ( kde-frameworks/kwallet:6 )
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KWALLETD=$(usex !kf6compat)
+ -DBUILD_KWALLET_QUERY=$(usex !kf6compat)
+ $(cmake_use_find_package man KF5DocTools)
+ )
+ if ! use kf6compat; then
+ mycmakeargs+=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ )
+ fi
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" "kde-plasma/kwallet-pam:5"
+ optfeature "KWallet management" "kde-apps/kwalletmanager:5"
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}