summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-07-27 11:08:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-07-27 11:08:39 +0000
commitd6106738e592139a894e86c22142da9ba45a13cb (patch)
tree32210c59fc55125033680e8c9e917e4573b3e15e
parentdev-libs/mongo-c-driver: keyword 1.18.0 for ~riscv (diff)
downloadgentoo-d6106738e592139a894e86c22142da9ba45a13cb.tar.gz
gentoo-d6106738e592139a894e86c22142da9ba45a13cb.tar.bz2
gentoo-d6106738e592139a894e86c22142da9ba45a13cb.zip
dev-db/timescaledb: Bump to 2.3.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.3.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index f6386920814b..97fe7c406449 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -3,3 +3,4 @@ DIST timescaledb-2.0.2.tar.gz 2237429 BLAKE2B 58c5e68daf5a3c1fade48b2ce8f625496e
DIST timescaledb-2.1.0.tar.gz 2527250 BLAKE2B 6f257c4b1afc0869c8e309f9b3080dbcdda4b50debc1a5b3848b9d6e59744ff52902b475aca0bc8820aa2edebe9847d62e500a8cd19f7ab8050d9586d95d3a66 SHA512 53fddb9fe4c4ab51ebc020e90eea5b032b41259d3bd45e8a03a86451acd7f8864b5a6ecba1b82b7c78e230f62cfddf1da75ff27e6629ad5fe8178839ac411ce4
DIST timescaledb-2.1.1.tar.gz 2534361 BLAKE2B d0aa5b231cbc9a75bb65eae395ffc0063a94bd3d9c47fe2b1f80bdf59c7624c83e3d4343f3d4ea402654627b8396936614f105fc7d01612f3ea03124471b44a3 SHA512 53bd8f9006741af834cc2598efe95b94e6ebf00df770ac3a4e0a087af83c8ba5ac2b1f421fd108e6609fde6bea725f05e2d590c3f341030a0f31edb6a3cf6cd5
DIST timescaledb-2.2.1.tar.gz 2637225 BLAKE2B 4ab37bb5c45a3f7550c2694c8757fff3e8dafe122aa9aea1e31d33931367b6b6bf8aa190444cd9472c3ba0aed087fa68d007ce52de24c78add3a53038a1d24ef SHA512 5dae0ed0b71309598bfc9605e838f2d8b4179ccf7098396315153c4044c7bdaaa411fd11ee70ca7807afde4b609faab281dcb1aa2f8d65330ca95e13fbe24582
+DIST timescaledb-2.3.1.tar.gz 2699256 BLAKE2B 5949245d4a2bf52558b3f646d3723b0571745226fcc0de236c21ad7f32316eaeb0780aa94f8ccacd420cd0b0e47c8e048172b9f9355cf01797398b7f2fc85a6a SHA512 431f716ecd98504ce8e5b85e6fd10bf87ed39aac0244b7e968383537caae965ece09f016fed8ea010f5d42b392aed2d75b012deafd807d107f3dc75cbde287ec
diff --git a/dev-db/timescaledb/timescaledb-2.3.1.ebuild b/dev-db/timescaledb/timescaledb-2.3.1.ebuild
new file mode 100644
index 000000000000..eba5dbffb770
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 13 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}