summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-22 15:39:25 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-22 15:39:25 -0600
commitd624438c02f1e00338747a43ede37c7f739e0f6a (patch)
tree35db64de14f1c6436eef7559137157c0b42a119d
parentgui-wm/sway: cleanup (diff)
downloadgentoo-d624438c02f1e00338747a43ede37c7f739e0f6a.tar.gz
gentoo-d624438c02f1e00338747a43ede37c7f739e0f6a.tar.bz2
gentoo-d624438c02f1e00338747a43ede37c7f739e0f6a.zip
gui-libs/wlroots: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.8.1-r1.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 4df0b03dc677..4fd35e3b5e48 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,2 +1 @@
DIST wlroots-0.10.0.tar.gz 454540 BLAKE2B 0d2326a62267019001be5f0d79c7b5c937ed20b952c92f0dd8cb04c3a0c06f3ef58723f552b1da1b947ea50ad91df46a543ec9705dad588db800bfa944743d11 SHA512 0e8e0c37f1afb1d99f0ecb3c2282992ffd06381aaa396c7234ead9f3ff2d5c599e766b677680ebaecf68e792054c3e42657d24f32d08bc8bcf35f9eb4bdaa876
-DIST wlroots-0.8.1.tar.gz 451814 BLAKE2B 85f221ba9068839f326e09df616f6182f518b9a129730dda794103305e3c0786d609a7cc6cb60a90c9d51cb77e3dbbc5993901271dcf1bd656c7744260561b06 SHA512 da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a
diff --git a/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild b/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
deleted file mode 100644
index 51f138afcfd2..000000000000
--- a/gui-libs/wlroots/wlroots-0.8.1-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit fcaps meson
-
-DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
-HOMEPAGE="https://github.com/swaywm/wlroots"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/8"
-IUSE="elogind icccm rdp systemd x11-backend X"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- >=dev-libs/libinput-1.9.0:0=
- >=dev-libs/wayland-1.17.0
- media-libs/mesa[egl,gles2,gbm]
- virtual/libudev
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pixman
- elogind? ( >=sys-auth/elogind-237 )
- icccm? ( x11-libs/xcb-util-wm )
- rdp? ( net-misc/freerdp )
- systemd? ( >=sys-apps/systemd-237 )
- x11-backend? ( x11-libs/libxcb:0= )
- X? (
- x11-base/xorg-server[wayland]
- x11-libs/libxcb:0=
- x11-libs/xcb-util-image
- )
-"
-RDEPEND="
- ${DEPEND}
- media-video/ffmpeg:0=
-"
-BDEPEND="
- >=dev-libs/wayland-protocols-1.17
- virtual/pkgconfig
-"
-
-src_configure() {
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
- local emesonargs=(
- "-Dxcb-errors=disabled"
- -Dlibcap=$(usex filecaps enabled disabled)
- -Dxcb-icccm=$(usex icccm enabled disabled)
- -Dxwayland=$(usex X enabled disabled)
- -Dx11-backend=$(usex x11-backend enabled disabled)
- "-Dexamples=false"
- "-Dwerror=false"
- )
- if use systemd; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
- elif use elogind; then
- emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
- else
- emesonargs+=("-Dlogind=disabled")
- fi
-
- # Patch is currently in upstream master
- eapply "${FILESDIR}/wlroots-0.8.1-eglmesaextfix.patch"
-
- meson_src_configure
-}
-
-pkg_postinst() {
- elog "You must be in the input group to allow your compositor"
- elog "to access input devices via libinput."
-}