summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:07:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:08:25 -0400
commitd628c07169a8e6bfa2c8dc24efcfad119913e253 (patch)
treef0978c434a709a9cd426576d735ddd06cba39708
parentnet-analyzer/nagios-plugins: new version 2.1.2. (diff)
downloadgentoo-d628c07169a8e6bfa2c8dc24efcfad119913e253.tar.gz
gentoo-d628c07169a8e6bfa2c8dc24efcfad119913e253.tar.bz2
gentoo-d628c07169a8e6bfa2c8dc24efcfad119913e253.zip
net-dns/rbldnsd: new revision with EAPI=6 and dropping eutils.
Package-Manager: portage-2.2.28
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.998-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-dns/rbldnsd/rbldnsd-0.998-r1.ebuild b/net-dns/rbldnsd/rbldnsd-0.998-r1.ebuild
new file mode 100644
index 000000000000..d20b87d363b5
--- /dev/null
+++ b/net-dns/rbldnsd/rbldnsd-0.998-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs user python-single-r1
+
+DESCRIPTION="DNS server designed to serve blacklist zones"
+HOMEPAGE="http://www.corpit.ru/mjt/rbldnsd.html"
+SRC_URI="http://www.corpit.ru/mjt/rbldnsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 test zlib"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS}
+ dev-python/pydns:2[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/rbldnsd-0.997a-robust-ipv6-test-support.patch"
+ "${FILESDIR}/rbldnsd-0.997a-format-security-compile-fix.patch"
+)
+
+src_configure() {
+ # The ./configure file is handwritten and doesn't support a `make
+ # install` target, so there are no --prefix options. The econf
+ # function appends those automatically, so we can't use it.
+ ./configure \
+ $(use_enable ipv6) \
+ $(use_enable zlib) \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_test() {
+ emake check \
+ CC="$(tc-getCC)" \
+ PYTHON="${PYTHON}"
+}
+
+src_install() {
+ einstalldocs
+ dosbin rbldnsd
+ doman rbldnsd.8
+ keepdir /var/db/rbldnsd
+ newinitd "${FILESDIR}"/initd-0.997a rbldnsd
+ newconfd "${FILESDIR}"/confd-0.997a rbldnsd
+}
+
+pkg_postinst() {
+ enewgroup rbldns
+ enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
+ fowners rbldns:rbldns /var/db/rbldnsd
+}