summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-10 03:12:26 +0000
committerSam James <sam@gentoo.org>2023-01-10 03:12:26 +0000
commitd667f0aca5e2855ecbf040bcfdb27d8db7aaf2bc (patch)
tree28538a2d1ca682496eee683a7b6eb02f2605499e
parentsys-libs/tdb: fix python-single-r1 usage (diff)
downloadgentoo-d667f0aca5e2855ecbf040bcfdb27d8db7aaf2bc.tar.gz
gentoo-d667f0aca5e2855ecbf040bcfdb27d8db7aaf2bc.tar.bz2
gentoo-d667f0aca5e2855ecbf040bcfdb27d8db7aaf2bc.zip
net-mail/fdm: add 2.2
Closes: https://bugs.gentoo.org/886525 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-mail/fdm/Manifest1
-rw-r--r--net-mail/fdm/fdm-2.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/fdm/Manifest b/net-mail/fdm/Manifest
index 43e26b5d3da1..ca39643a6375 100644
--- a/net-mail/fdm/Manifest
+++ b/net-mail/fdm/Manifest
@@ -1,2 +1,3 @@
DIST fdm-2.0.tar.gz 313596 BLAKE2B 8b323f4a8953a46773a4e5a1214444dc97db4346f50990fcfb4c9d79ae40bbb73b61e3bf41bc95b76e44f6bed7b398cb210d58901823752e92ca7b83189cbc7e SHA512 14e923202d17083ceb3b91b3a442d7e512c37f3d29535f22d8c0c4e1d57c97acc5d5465d643ed0cf437b3945ef777a6e38da3117219c2d54dcec88ecab1e10d9
DIST fdm-2.1.tar.gz 318803 BLAKE2B 2bb693177c69665d2354c382ab663a3283c5edae2cdf6f3bf2fe4133309de9d43e0e8ad3830eeee4eb002fe202eb20f982cdc892fb0b0d1698b13aa79f22be0a SHA512 6a864048e1f25eedbb6af86451b258678b91e3c225b3b065a1aeb043f125405dfa109a0fbd77363394e14050053c7d81093d5b9d6a2dd155fb00dc98455028b4
+DIST fdm-2.2.tar.gz 319140 BLAKE2B dde9126aaf3183444123bb3b546f8997a5a25f5dc58bb7fc08818e491e2193543f4f06e758b479e61da7feaf752e3d3ddfd8103c616a49f0d65c41972bae7e12 SHA512 13efa0f272c5f6146b90e094602e8a9b52016af79ae0b6cd80dc9f36b2ba37f64cadae7313bd8db90bcb007dd07206a3614987f11bb82c3535e04f0511c9fc6d
diff --git a/net-mail/fdm/fdm-2.2.ebuild b/net-mail/fdm/fdm-2.2.ebuild
new file mode 100644
index 000000000000..6f672a81bac9
--- /dev/null
+++ b/net-mail/fdm/fdm-2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fetch, filter and deliver mail"
+HOMEPAGE="https://github.com/nicm/fdm"
+SRC_URI="https://github.com/nicm/fdm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples pcre"
+
+DEPEND="
+ dev-libs/openssl:=
+ sys-libs/tdb
+ pcre? ( dev-libs/libpcre2 )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/fdm
+ acct-user/fdm
+"
+
+DOCS=( CHANGES README TODO MANUAL )
+
+src_prepare() {
+ default
+
+ # Change user '_fdm' to 'fdm'
+ sed -e 's/_fdm/fdm/g' -i fdm.h || die
+}
+
+src_configure() {
+ econf $(use_enable pcre pcre2)
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}